Correlation errors - indicating list does not exist... - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Correlation errors - indicating list does not exist...

Last post 07-02-2020 10:38 AM by Hilary Stoupa. 3 replies.
Page 1 of 1 (4 items)
Sort Posts: Previous Next
  • 07-01-2020 05:41 AM

    Correlation errors - indicating list does not exist...

    Hi All,

    I have just had to make changes to an InfoPath form (which has been running successfully for 4+ years.

    The changes that I have made are to do with concatenations of text - i.e. things like ABC\Fred.blogs needing to change to XYZ\Fred.blogs.  I have not changed any data connections - or any calls to data connections.

    The form runs fine from my pc. 

    When I publish the form and upload it to SharePoint (As a Managed Form)  I am getting correlation errors.

    "You do not have permissions to access a SharePoint list that contains data required for this form to function correctly.

    An entry has been added to the Windows event log of the server.

    Log ID:5566 "

     
    I couldn't find 5566 in the Event log of the front end servers. 

    I have looked in the SharePoint logs and there are several lines for the correlation ID - but the warning line in the logs is shown below with the line before

    07/01/2020 13:02:06.75  w3wp.exe (0x4348)                        0x1978 SharePoint Foundation          General                        8e2s Medium   Unknown SPRequest error occurred. More information: 0x80070002 08f0472e-2a78-41cc-b7aa-18c880645e14
    07/01/2020 13:02:06.80  w3wp.exe (0x4348)                        0x1978 InfoPath Forms Services        Runtime - Data Connections     eq8l Warning  The following query failed: Device Approvers (User: aBC\cwhit, Form Name: MobileDeviceRequestForm, IP: , Connection Target: , Request:
    http://sitename/_layouts/formserver.aspx?XsnLocation=/departments/IT/FormServerTemplates/MobileDeviceRequestForm.xsn&OpenIn=Browser, Form ID: urn:schemas-microsoft-com:office:infopath:MobileDeviceRequestForm:-myXSD-2014-11-29T06-34-09 Type: DataAdapterException, Exception Message: The form cannot run the specified query. The list could not be found.) 08f0472e-2a78-41cc-b7aa-18c880645e14
     

    There are about 10 lists which the form accesses and I have been disabling each one in turn to try and find the source of the error - but they all give the same error.

    All of the lists it is trying to access exist (I have been into SharePoint to double check - and no error is being thrown when I run from my own PC)

    The account this is being run from is admin on the site so should have access - and no error is being thrown when I run from my own PC)

    All users have read access to the lists.

    The data connections are in the form - not in a data connection library. 

    Have you any suggestions to get this working ?  (I have tried re-publishing the previous version - which has been working and that is now giving errors as well) 

    Catharine 

     

     

  • 07-02-2020 09:54 AM In reply to

    Re: Correlation errors - indicating list does not exist...

    Oh how horrible. This is an admin approved form? You are uploading to central admin? I think I'd try first uploading as a new form template (instead of updating existing) - just for testing. Take a copy of the form, publish with a different form name, see if you can upload to Central Admin. If that fails, I'd create a test form, just a new blank form, publish as admin approved, try to upload to central admin.... if that succeeds, add a data connection and try again. Just to sort of narrow things down - i.e., is it the template? The upgrade process in Central Admin? The data connection? The data connection in that specific template, and so forth. Does that make sense?
    Hilary Stoupa

  • 07-02-2020 10:32 AM In reply to

    Re: Correlation errors - indicating list does not exist...

     Hi Hilary

    Yes Admin approved form, uploading to central admin - if I click continue after the error - the form itself loads and has the latest version number in it - but none of the data from the attached tables is there - obviously.

     

    Catharine 

  • 07-02-2020 10:38 AM In reply to

    Re: Correlation errors - indicating list does not exist...

    Oh, so it uploads ok, just gives the error when you open it. Yeah, I would set up a test form, add the same data connection, admin approve it and see what happens when you open it.
    Hilary Stoupa

Page 1 of 1 (4 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.