Sharepoint Designer Workflow Issue - Fields Being Cleared - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Sharepoint Designer Workflow Issue - Fields Being Cleared

Last post 03-25-2009 07:55 AM by zxkuqyb. 1 replies.
Page 1 of 1 (2 items)
Sort Posts: Previous Next
  • 01-21-2009 07:32 AM

    • zxkuqyb
    • Not Ranked
      Male
    • Joined on 01-14-2009
    • Indianapolis, IN
    • Posts 18

    Sharepoint Designer Workflow Issue - Fields Being Cleared

    I am really struggling with something pertaining to Sharepoint Designer and it's Workflow and I am hoping someone has experienced the same issue and can provide some insight.  Here's what happens:

    We're using MOSS and I have a Form which I've developed using InfoPath 2007.  The form is published as Infopath 2003 because not all users are on '07 yet and I have to maintain backwards compatibility.  For some reason, and here's where I hope someone can help me, something is happening to either the site, the form, permissions, etc., on occasion, and ALL of the workflow settings being cleared / reset.  An example looks something like this:

    A correct working example:

    Step 1

    CONDITIONS:  If Approver_Comments equals TRUE

    ACTIONS:  Email Form1:CreatedBy

    The email body includes some text and then some inserted field references to make for a nice reference / message to the Original Creator of the Form.

    ---------------- 

    THEN, the weirdness happens...The workflow settings seem to get "reset" and when I open Sharepoint Designer to view the workflows, they all look something like this:

    Step 1

    CONDITIONS: If field equals TRUE

    ACTIONS: Email Form1:CreatedBy

    The email body still retains it's original text, BUT, every field that I used to reference has been replaced with Form1:field, INSTEAD of the FIELD NAME that I used to have referenced.

    ----------------

    I appologize, because the example above is very crude.  I have about 12 different workflows that I have configured which include multiple conditions and actions, but didn't feel it was necessary to post them all here, to explain the anomoly.  Does anyone have any idea as to why this is happening?  It's so frustrating as I've had to "re-build" the workflow at least 12 times.  My biggest concern is that this anomoly will happen, and the workflow will reset in the middle of it's processing.  Then I will really have a mess on my hands.  Fortunately, I have not rolled this form out to the general user community, however, Pilot is supposed to happen in about 10 days and general rollout a few weeks later.  The form / process will be capturing signatures all the way up to the CEO, so, in light of the issue at hand, my stress level is very high.  I would be extremely grateful to anyone who can provide some insight as to why this is happening and any possible solutions.

    Thank you,

    Tom

    Thomas N. Barrett
  • 03-25-2009 07:55 AM In reply to

    • zxkuqyb
    • Not Ranked
      Male
    • Joined on 01-14-2009
    • Indianapolis, IN
    • Posts 18

    Re: Sharepoint Designer Workflow Issue - Fields Being Cleared

    For what it's worth:

    While searching for an answer out on the web, I was able to find someone else who experienced the same issue.  Here's a link to what they experienced.  It appears to be a SharePoint Server Timeout issue.  I'm not sure of the solution (probably more of a Server Admin thing), but I'm feeling better about what causes the issue I've experienced.  Hopefully this will help someone...

    http://acuffgroup.com/2009/01/21/tip-for-publishing-infopath-form-to-sharepoint-library/

    Thomas N. Barrett
Page 1 of 1 (2 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.