get-Role() how to remove? - InfoPath Dev

InfoPath Dev

Use our Google Custom Search for best site search results.

get-Role() how to remove?

Last post 04-12-2019 06:00 AM by Laurie Wheeler. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • 11-21-2008 04:27 PM

    • vzh65c
    • Not Ranked
    • Joined on 08-31-2007
    • Chicago
    • Posts 1

    get-Role() how to remove?

    Converting a IP2003 form to a IP2007 Form Services capable form.  No scripting... no managed code.  Just GUI configuration.

    I took care of all the conflicts except one.  I keep getting an "Unsuported Expression" error, related to  xdXDocument:get-Role().  I've gone through all the controls and verified that they didn't have any rules applied to them.  This error only occurs if I have the "Verify on server" checked.  If I don't, then there are no problems. (except when I attempt to upload the template into SP).  I show ALL of the messages in the Design Checker.

     Using Logic Inspector... it all comes up blank.

     The form has 3 views.  In each of the .xsl files, I have something like the following. (One of the views has 1 line of get-Role(), one has 2 lines of get-Role(), one has 3 lines  of get-Role())

          <xsl:attribute name="style">
                <xsl:if test="xdXDocument:get-Role() = &quot;Employee&quot;">msos-xCollection-FunctionalCompetency_97-editing:disabled;</xsl:if>
                <xsl:if test="xdXDocument:get-Role() = &quot;Employee&quot;">msos-xCollection-FunctionalCompetency_264-editing:disabled;</xsl:if>

    Now I know that I can go into the the XSL files strip this out (at the attribute level), resave the files, rebuild the CAB and rename it to an XSN and theoretically all should be good.  (I've verified that get-Role() doesn't exist in any of the other source files). 

    I seem to be missing something somewhere and I'm not sure where else to check.  I looked at the Form Options to see if there was anything there... nada. 

    In a group section properties, on the Advanced Tab, under the Code section I notices that there is the following:  "ViewContext: CTRL122"  not sure if this has anything to do with it.

    I've recreated the group (in all three views). Still get error.

    I've created three new views (copied and pasted the old views into them), deleted the old views.  Still get error.

    Not sure if it's even related to this Group.  When I click on the error in design checker it doesn't pull up anything.

    My question is how can I get rid of the error short of modifying the source files?  Fix the problem Instead using just the GUI.

    Any thoughts or suggestions are appreciated. 



    Filed under:
  • 11-21-2008 04:39 PM In reply to

    Re: get-Role() how to remove?

    Hi, and welcome:

    My guess is that this is conditional formatting. As such, it would be based on the control, not the field, so that is why the Logic Inspector doesn't show anything. The ViewContext: CTRL122 is the control id, that shouldn't have anything to do with this issue.

    If you look at the conditional formatting for the sections (or repeating section or table) bound to the groups, is there anything?

    Hilary Stoupa

  • 04-12-2019 06:00 AM In reply to

    Re: get-Role() how to remove?

    I just created a new post for this same situation. I even went so far as to remove the old rule, saved, published, then replaced the rule with a new one, saved and published. When I extracted the files and reviewed the same xsl file, the same old logic was still in the file... in my case this is abundant over 500 times.
    Laurie Wheeler
Page 1 of 1 (3 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.