Dynamic Help Problems - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Dynamic Help Problems

Last post 02-04-2005 11:59 AM by Rip. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • 02-04-2005 09:14 AM

    • Rip
    • Not Ranked
    • Joined on 02-04-2005
    • USA
    • Posts 20

    Dynamic Help Problems

    I have been trying to implement the Dynamic Help example for my own form. When the form loads I get the script error that the DataObject "Help" does not exist. After compairing my manifest.xsf file to the downloaded example I found the folloing section missing:

    <xsf:dataObjects>
    <xsf:dataObject name="Help" schema="Help.xsd" initOnLoad="yes">
    <xsf:query>
    <xsf:xmlFileAdapter fileUrl="Help.xml" name="Help"></xsf:xmlFileAdapter>
    </xsf:query>
    </xsf:dataObject>
    </xsf:dataObjects>

    I am adding the resouce files(htm, css, help.xml, and js file) to the form. What am I missing? Thanks for your assistance

    Richard T. Henry
    Lewisberry, PA, USA
    riphenry@gmail.com
  • 02-04-2005 10:13 AM In reply to

    I think you'll find that if you add Help.xml as a Data Connection instead of a Resource File, that things will work out better.

    Greg Collins [InfoPath MVP]
  • 02-04-2005 11:59 AM In reply to

    • Rip
    • Not Ranked
    • Joined on 02-04-2005
    • USA
    • Posts 20
    Greg,
    Thanks I have got it working about 90% correct.

    Rip

    Richard T. Henry
    Lewisberry, PA, USA
    riphenry@gmail.com
Page 1 of 1 (3 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.