Manual Publishing? - InfoPath Dev

InfoPath Dev

Use our Google Custom Search for best site search results.

Manual Publishing?

Last post 06-04-2021 11:45 AM by Hilary Stoupa. 9 replies.
Page 1 of 1 (10 items)
Sort Posts: Previous Next
  • 06-04-2021 08:13 AM

    Manual Publishing?

    Over the course of the last ~30 days, publishing to SharePoint has become increasingly unreliable, to the point as of a few weeks ago where it has become altogether impossible.

    Any time I select a site and click next in the Publishing Wizard, I am met with the error message:

    "InfoPath cannot find or cannot access the following Web server: (my site) Make sure that the Web server name is valid, that your proxy settings are correct, and that you have the necessary permissions to publish to this library. If the server requires you to log on through the browser, log on there and select the option to remember your log on information, then try to publish again."

    Unfortunately I don't really know what any of that means :) The site is correct; I have been doing this exact thing for 5 years. Prior to a few weeks ago I was able to just dismiss the error message and continually attempt to publish, and eventually after a few minutes of trying it would randomly connect. No such luck anymore.

    I have a ticket in to my IT department, but they are dragging their feet and my users want changes now! Is there some way of "publishing" to SharePoint manually, without using the wizard? I assume it cannot be as simple as just dropping a new .xsn into /Forms/ in the document library. In fact I believe I tried that before and it just ended up breaking with a "this form cannot be opened in a Web browser. To open this form, use Microsoft InfoPath."

    I want my company to buy me FormsViewer, I assume that would also mitigate this issue? We'll see if they spring for it, though.

    edit: what the heck I had to go add br tags to show line breaks in my post! haha
  • 06-04-2021 09:13 AM In reply to

    No, I'm sorry, there isn't a way to manually publish. Is the SharePoint on Office 365? or on-prem? FormsViewer DOES solve the publishing problem - you literally just drag and drop your XSN onto a web page and click an "upload" button. No more publishing (thank goodness). Yeah, sorry about the formatting on the forum, the software is old and works best with IE. Let us know if you you want someone at Qdabra to schedule a FormsViewer demo for you. :)
    Hilary Stoupa

  • 06-04-2021 09:39 AM In reply to

    Thanks for the quick response as always :)

    We are on Office 365/Online. I personally would love a demo, but I'll have to wait to hear back from management if they're even going to consider my proposal.
  • 06-04-2021 09:47 AM In reply to

    I'm not surprised to hear that you are using Office Online.... I feel like they are just gradually making the experience of using InfoPath Browser forms worse and worse (or just aren't testing at all as part of their update process) and that eventually, it is all gonna catastrophically fail, you know?
    Hilary Stoupa

  • 06-04-2021 09:51 AM In reply to

    No doubt. Everything I have published already is still working, but I am completely unable to make any form updates. I honestly have no idea if the issue is from Microsoft updates or something internal. Thanks for the help; hopefully I'll have good FormsViewer news soon :)
  • 06-04-2021 09:56 AM In reply to

    One more question if you don't mind.... Are these list forms? Or library? Just wondering. I updated and published a list form to our tenant the other day experimenting with something and was sort of surprised that I didn't have any trouble. I'm including a screenshot of my InfoPath version (just in case that's helpful).
    Hilary Stoupa

  • 06-04-2021 10:20 AM In reply to

    Document Library forms I believe? I am not totally sure if I know what a list form is...

    I have in the past used both Infopath 2010 and 2013, but we have a rather convoluted setup going on right now. We have to log in to a Citrix virtual desktop to run InfoPath, but then the 2013 version stopped working when our company implemented Multi-Factor Authentication to our accounts. 2013 became unusable due to a "your account is in a bad state" error that has yet to be resolved. 2010 was fine for about 2 months before my publishing issue started up.
  • 06-04-2021 11:18 AM In reply to

    MFA will work with IP 2013 with some registry key changes (which probably means bringing in IT). Here's a link:
    Hilary Stoupa

  • 06-04-2021 11:39 AM In reply to

    Oh yeah, I've been to several forums detailing registry changes like that; I'll give this one a shot as well, but I was not successful before :(

    Thanks for everything
  • 06-04-2021 11:45 AM In reply to

    That's the one that has worked for me with InfoPath 2013 and Office MFA - I also need it for SharePoint Designer for clients that use MFA. Hopefully it will work for you. :)
    Hilary Stoupa

Page 1 of 1 (10 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.