People Picker is not working in sharepoint online after the migration - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

People Picker is not working in sharepoint online after the migration

Last post 01-21-2021 08:01 AM by Hilary Stoupa. 7 replies.
Page 1 of 1 (8 items)
Sort Posts: Previous Next
  • 12-22-2020 01:53 AM

    People Picker is not working in sharepoint online after the migration

    Hi All,

      I am currently migrating my SharePoint 2013 farm to SharePoint Online. While migrating I am getting a issue with InfoPath People picker control.

    When I open a old form in SharePoint Online user names are not getting auto verified and if m I create a new form it works fine , I need to fix that issue as I have more than 1000 records and I cant do the changes manually.

    Please let me know if anyone faced same issue or solved it already.

     

     

    Regards,

    Sachin Patekar 

  • 12-22-2020 08:48 AM In reply to

    Re: People Picker is not working in sharepoint online after the migration

    I'd compare an XML from the new environment with one that was migrated (i.e., one where the people picker resolves vs. one where it doesn't). Look at the account id in the person field - it probably starts with a claims prefix in the new environment. If your people picker is for a single person, you may be able to fix the account id up with form load rules. Personally - I'd save all the XML files locally and use PowerShell to fix them up, then re-upload them after I'd verified a few....
    Hilary Stoupa

  • 12-22-2020 07:50 PM In reply to

    Re: People Picker is not working in sharepoint online after the migration

    Thank you for the reply but I don't know much about PowerShell.

    if you have a link from where I can refer and resolve this that will be very helpful.

     

  • 12-23-2020 02:14 PM In reply to

    Re: People Picker is not working in sharepoint online after the migration

    Is your people picker for a single person? or multiple? If single you could do this with form rules.
    Hilary Stoupa

  • 12-30-2020 09:23 PM In reply to

    Re: People Picker is not working in sharepoint online after the migration

    My people picker is single person.

    Can you Please guide me with the rules? 

  • 01-04-2021 07:37 AM In reply to

    Re: People Picker is not working in sharepoint online after the migration

    Can you look at the value in the field (by downloading the XML and opening with a text editor) where the field is correctly resolved in the new eviro vs. an old form? And let me know what you see?
    Hilary Stoupa

  • 01-20-2021 10:01 PM In reply to

    Re: People Picker is not working in sharepoint online after the migration

    I can see the change in login name function earlier it was " i:0#.w|" and now it is " i:0#.f|membership".

     

  • 01-21-2021 08:01 AM In reply to

    Re: People Picker is not working in sharepoint online after the migration

    So - you could have a form load rule that if the field starts with "i:0#.w|", set it to substring-after "i:0#.w" concatenated with "i:0#.f|membership". I'm attaching a simple sample with this rule on a button. Right click the linked form, save locally. Right click the locally saved XSN and select Design to open in Design mode.
    Hilary Stoupa

Page 1 of 1 (8 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.