Information in Infopath form not visible in Sharepoint (previously was) - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Information in Infopath form not visible in Sharepoint (previously was)

Last post 11-15-2020 05:23 PM by Jays_D. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • 11-10-2020 05:39 PM

    Information in Infopath form not visible in Sharepoint (previously was)

    Hi Everyone, I have a Infopath form that has a 'Customer' field, assigned to a 'Customer' column in SharePoint Online 2013 Form Library. We published a refreshed form (design only) back to the site and for some reason, this 'Customer' column is now blank for any items in Sharepoint before the change was made, anything new is OK (can see Customer name). If you open the Infopath form for one of these older deals, and just click Save and close - it corrects that column for that item and shows the 'Customer' name. Any indication as to what may cause this and is there a way to refresh it without opening every single form and clicking save? (There are literally hundreds). Thank you
  • 11-11-2020 07:50 AM In reply to

    Re: Information in Infopath form not visible in Sharepoint (previously was)

    So - just opening them should update the field. You shouldn't even have to click Save. As I mentioned in your other thread, if you could open the library in File Explorer and copy the files out, that would update them. I wonder if you copied the files out via PowerShell if that would do the same thing? It may be worth a try rather than having to open them all... I think there is some freeware out there that can also be used to copy files (SPFileZilla - https://github.com/bandrben/SPFileZilla2013). Again - not sure if using that to copy will update metadata, but seems worth a try. :)
    Hilary Stoupa

  • 11-15-2020 05:23 PM In reply to

    Re: Information in Infopath form not visible in Sharepoint (previously was)

    Thank you Hilary and apologies for the late reply ! I am very restricted in what I can do with back end and for some reason, it won't open in File Explorer. Additionally, our IT department do not support Infopath made solutions. We've had to engage Microsoft who are in-fact looking at cleaning this up in Powershell. I might try and open each Infopath form and close, just to see if it does refresh without saving, again, mammoth task but it may help some-what. Thank you again Hilary.
Page 1 of 1 (3 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.