InfoPath Webpart Connections - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

InfoPath Webpart Connections

Last post 10-15-2020 04:09 PM by Hilary Stoupa. 3 replies.
Page 1 of 1 (4 items)
Sort Posts: Previous Next
  • 10-13-2020 01:23 PM

    InfoPath Webpart Connections

    I'm trying to connect an infopath webpart to a list view webpart. From what I can tell everything should be working problem, but when the "value" gets sent to the list view webpart, it always filters it for blank, even when the provider field (in the infopath form) has something in it. I've attached my form here. I want to use the dropdown for "SO number" and send that value to a list view. I've even created a button that will submit to webpart, tried rules on the dropdown, but I always end up with a "blank" filter on the list. Is this possible? Thanks
    Filed under:
  • 10-14-2020 02:00 PM In reply to

    Re: InfoPath Webpart Connections

    So i've done some testing and the only thing that makes sense is that I cannot connect these two web parts because the field that I want to use to conec them is a lookup column. So my thought is to have a helper field (text) that I send the "SO Number" to. The issue is that Infopath wants to send the ID of the lookup, which on it's own I'm fine, but the SPD workflow I am building to fill this Helper field on all the current entries either enters a text value or a string with ID and number. So I can get the ID with infopath and the text value with SPD. How would I either use Infopath to display the value from the lookup rather than the ID, or should I find a way to get SPD to return the ID of the lookup item. Does this all even make sense? Thanks
  • 10-15-2020 09:28 AM In reply to

    Re: InfoPath Webpart Connections

    just an update, this connection definitely won't work because it's a lookup column. I've created a helper field (text) in infopath and am dropping the value of the lookup into it, and I've created a workflow that will do the same for all the current items. No more help required on this issue :)
  • 10-15-2020 04:09 PM In reply to

    Re: InfoPath Webpart Connections

    Glad you got it sorted out, and thanks for posting the info to help others!
    Hilary Stoupa

Page 1 of 1 (4 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.