Dropdown blank space - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Dropdown blank space

Last post 08-27-2008 12:44 PM by Rager. 10 replies.
Page 1 of 1 (11 items)
Sort Posts: Previous Next
  • 07-21-2008 11:18 PM

    Dropdown blank space

    Hi, I'm trying to retrieve values into dropdown in Infopath2007 from External datasource i.e., fom SQL server 2005..Values are retieving sucessfully but follwed by blank space.Why it is happening?????How to avoid the blank space comming on retrival......When manually entering values into drop down therz no such blank space found........why itz happening only when trying to retrieve for External datasource?????

  • 07-21-2008 11:40 PM In reply to

    • Shiva
    • Top 25 Contributor
    • Joined on 04-15-2005
    • India
    • Posts 694

    Hello Susmitha Welcome to the Forums,

    Whenever we displaying the dropdown values of manual and we have a option called to set default value. Because of here we don’t have option called blank.

    For external data source connecting we might have a chance to those entries might not be have any value. For this binding is directly to node but not a value. In manual adding values is we can directly point those values to dropdown list. But in external source we don’t have option called to bind the value of set of nodes to dropdown list. For this it will show the blank value for retrieving from external data source.

    If you want to show always first value in dropdown then you can add one rule to set first value of external data source to dropdown list.

  • 07-21-2008 11:40 PM In reply to

    • Anuma
    • Top 25 Contributor
      Female
    • Joined on 07-20-2005
    • India
    • Posts 525

    Hi,

     

     Can you add one filter condition while connecting the dropdown list box to secondary data source?

    Add filter condition as “Field” is not blank.

     

    Field à from which field in secondary data source you are getting data to the dropdown field.

     

    Anuma Chinthapalli /
    http://www.GGKTech.com
  • 07-21-2008 11:52 PM In reply to

    • jeeva
    • Top 150 Contributor
      Male
    • Joined on 07-18-2008
    • Bangalore
    • Posts 79

    Hi,

    In my case connecting dropdown box to form's data source?

    how can i remove that blank . 

  • 07-22-2008 12:05 AM In reply to

    Thanq....But am not able to add the filter condition.......can u please make it clear....My form is a browser enabled form......

  • 07-22-2008 12:07 AM In reply to

    Thanq...But am not successful in adding filter....so can u please make it clear.My form is browser enabled
  • 07-22-2008 12:19 AM In reply to

    How can i set the first value of external datasource to the dropdown....Is there any solution for not displaying the blank value??????

  • 07-22-2008 12:36 AM In reply to

    Dropdown

  • 07-22-2008 12:49 AM In reply to

    • Shiva
    • Top 25 Contributor
    • Joined on 04-15-2005
    • India
    • Posts 694

    Hello Susmitha,

    You have to add the rule and follow these steps,

    1. Rules -> ‘Add’ - > ‘Add Action’.

    2. Select ‘Set a field value’ option in first dropdown in Action.

    3. Select your field with help of ‘Select a Field or Group’ option in ‘Field’.

    4. Select your external data source list value in ‘Value’.

    This rule you can apply in OnLoad or whenever you will get external data source values.

  • 07-22-2008 09:52 PM In reply to

    • jeeva
    • Top 150 Contributor
      Male
    • Joined on 07-18-2008
    • Bangalore
    • Posts 79

     Hi Siva,

    I try your steps but its not working in my forms. 

  • 08-27-2008 12:44 PM In reply to

    • Rager
    • Not Ranked
    • Joined on 08-27-2008
    • Posts 1

    ... agree ((

    Hi all,

    I have the similar problem, but with some "extensions". I've developed the Loading event hander in the managed code of browser-enabled form. I fill the drop-down list there using the data from the list located on SharePoint site. For example, SP list contains the following data (string):

    1. one
    2. two
    3. three

    But when I open the form in the browser I get the following result:

    1. <blank>
    2. three
    3. one
    4. two
    5. three

    How can I delete the "three" on point 2? <blank> can't be deleted as I heard (or can yet?? - would be great). But what about "three"? I tied to edit view1.xsl file located within .xsn - nothing happens (if I just hard-code the values within this file - no <blank> and "three" are displayed).

Page 1 of 1 (11 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.