Invalid form template error - Invalid or malicious HTML was found in view <view> - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Invalid form template error - Invalid or malicious HTML was found in view <view>

Last post 11-05-2021 11:17 AM by dsmith45. 3 replies.
Page 1 of 1 (4 items)
Sort Posts: Previous Next
  • 11-03-2021 06:36 PM

    Invalid form template error - Invalid or malicious HTML was found in view <view>

    Hi, I have created a new form, it's quite busy with many sections and many things that happen using Rules (like hiding of sections if something is "False", etc.). Upon adding a new section today, I started getting Design Checker errors saying "Invalid form template error", and when I click on that, the message "Invalid or malicious HTML was found in view " (my page name). Now I can't open the form in a browser like I could 3 hours ago! I'm not sure what I did, and I've spent the last 3 hours trying to fix it, but not sure how to do so. In the Form Options/Security and Trust, it is set to "Auto", Compatibility is set to "Web browser Form (InfoPath 2010)", and just something that recently appeared in that page, "http://headofficexxxx.xxxxxx.com/Corporate/libraryname/_vti_bin/FormsServices.asmx", and I'm not sure where that came from. I tried taking it out, but it keeps re-appearing by itself. Could this be the cause? We are just about to migrate to this new form after many years of using a previous form, and now we can't because we are getting these error messages, and I have no way of fixing it because I don't totally know what the problem is or why I'm getting the errors. The error message is very obscure and doesn't tell you where the exact error lies. There is nothing else wrong with the form, except that it's saying "Merged print views are not supported" under the Invalid Form Template message in the Design Checker. I need help please, I can't figure this out on my own. My team thinks I'm the "form wiz", and if I can't get this working again I'm going to have to spend countless hours reprogramming the entire form from scratch. Thank you.
  • 11-04-2021 07:31 AM In reply to

    Re: Invalid form template error - Invalid or malicious HTML was found in view <view>

    Hi! So - the URL you are seeing on the compatibility is the URL for forms services (InfoPath browser form support) on your server. That is an expected thing - when you publish, the form is checked against forms services to verify it is valid.
    Hilary Stoupa

  • 11-05-2021 10:56 AM In reply to

    Re: Invalid form template error - Invalid or malicious HTML was found in view <view>

     Ok, we figured this one out via email.

    We installed Fiddler, and ran a trace while using design checker. That told us which line in which view had the error.  For some unknown reason, InfoPath had added "scroll: auto" to the body tag style attribute in the view. Manually removing that allowed the form to pass design checker, publish and be opened in the browser again.

    Hilary Stoupa

  • 11-05-2021 11:17 AM In reply to

    Re: Invalid form template error - Invalid or malicious HTML was found in view <view>

    Outstanding service, Hilary. You're a champion! Too bad InfoPath and SharePoint are no longer supported, but I'll keep coming back here if we run into any more issues in the future! Dan
Page 1 of 1 (4 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.