Connecting to UDCX failure getting data from SharePoint Server - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Connecting to UDCX failure getting data from SharePoint Server

Last post 04-16-2019 11:32 AM by SeanPRyan. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • 04-12-2019 02:07 PM

    • SeanPRyan
    • Top 500 Contributor
      Male
    • Joined on 02-02-2012
    • Kansas City area
    • Posts 43

    Connecting to UDCX failure getting data from SharePoint Server

    I am operating on a SharePoint 2016 on premises environment and using InfoPath Designer 2013. I created an InfoPath Web Browser Form Template and successfully established a udcx connection file for my site collection :serverAlias/sites/MySite (intranet) and it works fine for the form wherein I established said connection. Now, I am trying to connect to that same file in a second form in the very same site collection without success. On my new form I choose the data tab to get external data and click Form SharePoint Server icon. I select my site as shown above > the data connection library shows and I expand the item to show my GetUserProfileByName connection, but when I click next, it fails. InfoPath cannot find or cannot access the specified Web service description. Details: The data source file is accessed through a redirection from a different domain, which is not allowed. If you want to use this data source file, copy it to a location within your security domain. Access is denied. This library is adjacent to the one where the connection works. Connection Options are: Local data connection library Format: UDC V2; Connection Type: WebService; Purpose: ReadOnly; Generated by Microsoft InfoPath 2010 on 2019-02-14 at 10:20 by domain\myname. Type: Web service Allows: Receive Any help is much appreciated!
    Sean
  • 04-15-2019 07:50 AM In reply to

    Re: Connecting to UDCX failure getting data from SharePoint Server

    Hey - I've had some similar issues and the only thing that's worked for me is creating the data connection as new, then when I convert to UDCX, overwriting the existing UDCX (or just updating the manifest manually to convert to UDCX, which is actually what I'm more likely to do) - Hopefully someone else will have a more helpful suggestion.
    Hilary Stoupa

  • 04-16-2019 11:32 AM In reply to

    • SeanPRyan
    • Top 500 Contributor
      Male
    • Joined on 02-02-2012
    • Kansas City area
    • Posts 43

    Re: Connecting to UDCX failure getting data from SharePoint Server

    Thanks so much Hilary. I am creating a new connection and then tying to the same target application id in Central Admin and it is working well.
    Sean
Page 1 of 1 (3 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.