Repeating Table to list in Browser Form - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Repeating Table to list in Browser Form

Last post 04-09-2019 11:44 AM by Hilary Stoupa. 7 replies.
Page 1 of 1 (8 items)
Sort Posts: Previous Next
  • 04-09-2019 07:45 AM

    Repeating Table to list in Browser Form

    I have an InfoPath 2013 form published to a SharePoint 2013 form library. The form includes a repeating table. I am using the Webinar from 2/28/13 by Patrick Halstead to perform the OOB actions to submit line items to a list. I am successful when submitting in the InfoPath FILLER form, but when submitting in the Web Browser form on SharePoint it fails. Is there an area that I overlooked? Do you know if this submit is even possible in a Web Browser form?
  • 04-09-2019 07:54 AM In reply to

    Re: Repeating Table to list in Browser Form

    What's the failure? I'm not sure what the OOB actions are (as far as I know, there isn't really an OOB way to submit to a list - are you using CAML / web services?) - if it is using the lists.asmx service, you may have some settings that need to be changed on your SharePoint server to be able to execute a web service request to SharePoint web services from the browser.....
    Hilary Stoupa

  • 04-09-2019 08:02 AM In reply to

    Re: Repeating Table to list in Browser Form

    Yes, using CAML/web services, and the lists.asmx service. When I submit it from InfoPath it will submit the lines to a list and publish the form. But when use the form as a browser form on SharePoint I get a SharePoint message that says "The form cannon be submitted because of an error" and then under detail it says "An error occurred while trying to connect to a web service". There is Log ID and Correlation ID. I do not not have admin rights to the server, so if it's an issue with settings I will probably need to steer them somewhat.
  • 04-09-2019 09:05 AM In reply to

    Re: Repeating Table to list in Browser Form

    They likely need to disable loopback check. You should get them the correlation ID and time of the error, so they can review the logs.
    Hilary Stoupa

  • 04-09-2019 11:08 AM In reply to

    Re: Repeating Table to list in Browser Form

    Our Admin says that it is not best practice to disable the loopback check .. could I send you the log information to look at? It's in an excel file. Maybe there is a different issue showing in the log. I've spent a lot of hours/days on this and at this point it would help to know if I am the one doing something wrong or if the server is just not letting me. He is also wondering if it's a permissions issue.
  • 04-09-2019 11:24 AM In reply to

    Re: Repeating Table to list in Browser Form

    If the error message you are getting includes "5566", your SharePoint admin can take the first approach outlined in this KB as well to specify host names: https://support.microsoft.com/en-us/help/896861/you-receive-error-401-1-when-you-browse-a-web-site-that-uses-integrate
    Hilary Stoupa

  • 04-09-2019 11:37 AM In reply to

    Re: Repeating Table to list in Browser Form

    The Log ID is 5567, does that help? I've attached a screenshot.
  • 04-09-2019 11:44 AM In reply to

    Re: Repeating Table to list in Browser Form

    I'm more used to seeing a 5566, but if the error in the logs is a 401, unauthorized, direct your admin to the KB I linked to - there are options other than disabling loopback outlined there.
    Hilary Stoupa

Page 1 of 1 (8 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.