qRules - not getting very far - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

qRules - not getting very far

Last post 08-19-2016 08:06 AM by Hilary Stoupa. 4 replies.
Page 1 of 1 (5 items)
Sort Posts: Previous Next
  • 08-18-2016 02:04 AM

    qRules - not getting very far

    I've just downloaded the latest version of qRules as a trial and have so far only read the Quick Start guide. I've installed the product, created a blank InfoPath form and injected qRules into it. I'm now following the tutorial in the guide which walks you through creating a couple of date fields and calculates the difference between them. However, when I go to preview my form to see it in action I get the following error message:

    "InfoPath cannot open a new form. The form template is not valid"

    "InfoPath cannot open the selected form because of an error in the form's code. Object reference not set to an instance of an object."

    Not exactly explanatory! :-(

    I'm using InfoPath 2013 and my form is browser compatible. qRules installed successfully and the form was successfully injected.

    Anyone know what I've done wrong?

    Thanks in advance for your help. 

     

  • 08-18-2016 12:05 PM In reply to

    Re: qRules - not getting very far

    You are right, that is not very helpful! Can you attach your template under the Options tab in a reply so I can take a look / see if it previews on my machine and get you some troubleshooting suggestions?
    Hilary Stoupa

  • 08-18-2016 12:06 PM In reply to

    Re: qRules - not getting very far

    Also - did you inject w/ Admin selected in the injector? If so, maybe try again with Sandbox selected. :)
    Hilary Stoupa

  • 08-19-2016 01:49 AM In reply to

    Re: qRules - not getting very far

    Hi Hilary,

    Thanks for the quick reply. 

    I think I may have discovered the problem by installing qRules on another machine. On the second machine qRules works as described in the documentation. My first machine is a server and is running Windows 2012 R2. The second machine is a PC running Windows 10. I don't believe it's the operating system that is significant though. If I look at the version of InfoPath that is running on the two machines I can see that that the server is running the 64-bit version of InfoPath 2013 whereas the PC is running the 32-bit version of InfoPath 2013. In other words I don't think qRules works with 64-bit InfoPath (or perhaps it does with a tweak?). Could you comment on that?

    Regards,

    J. 

    Filed under:
  • 08-19-2016 08:06 AM In reply to

    Re: qRules - not getting very far

    qRules does work with the 64 bit version - I have Windows 10 & use 64 bit Office. I think the issue is with the OS somehow.
    Hilary Stoupa

Page 1 of 1 (5 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.