InfoPath 2013 SharePoint 2010 - Network Path was Not Found - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

InfoPath 2013 SharePoint 2010 - Network Path was Not Found

Last post 09-14-2016 05:01 PM by ThisIsTonya. 4 replies.
Page 1 of 1 (5 items)
Sort Posts: Previous Next
  • 05-16-2016 08:15 AM

    InfoPath 2013 SharePoint 2010 - Network Path was Not Found

    Hi,

    I am having a newly developed issue, with publishing InfoPath Forms to SharePoint Forms Libraries.  I have successfully created, published and updated SharePoint Forms Libraries in the past.  However as of last Monday, I started getting "network path was not found".

    My Permissions:
    Farm Administrator (I have full permissions to every object within our environment)

    Steps I take: 
    1) Create InfoPath Form (.xsn)
    2) Create SharePoint Forms Library
    3) Tell InfoPath to Publish Form to SharePoint Library
    4) Tell InfoPath the SharePoint Site Name
    5) Tell InfoPath that I want to create or modify a Form Library
    6) Tell InfoPath that I want to Update Existing Form template
    7) Select Appropriate Forms Library and Publish

    Error Received:
    InfoPath cannot save the following form: https://SiteAddress/SiteCollection/SubSite/Library the network path was not found 

     

    This has always worked for me in the past.  I have done this, within this environment close to a thousand times prior to this.

     

    Notes:
    1) Our Domain Controller which we have no direct control over, was recently reset (Monday)
    2) I can choose create an new Forms Library and it will create said library and the Form will work.  However, if I attempt to update the Form on that Library I receive the error above.
    3) At times (Not always) If I create a new Forms Library and then take an existing template and try to publish to said library, the library won't be displayed as available for 10 or so minutes.
    4) I have built a new box and reinstalled all of the software (I did this for testing)
    5) I have used other Computers and the issue is still present (though the first update on the new box will at times go through. However additional will not)
    6) I have tried this using other Administrators Credentials and the symptoms persist) 


    I'm literally out of things to try and google has failed me (though it never has before).  so Help me please..... pretty please... lol

    Good... Bad... Im the guy with the gun.
  • 05-16-2016 08:30 AM In reply to

    Re: InfoPath 2013 SharePoint 2010 - Network Path was Not Found

    Additional Notes:

    I have attempted this across many Site Collections and many, many times.  The issue is persistent for sure but I feel as if I have finally gotten it down to one definitive symptom.  If I publish a Form to a Library a single time, it will work. Regardless of rather I created the Library during the publish or prior.  However, if I attempt to publish it a seconds time the error appears.  Regardless of rather I Edit existing Template (advanced settings of Forms Library) or if I simply open the Template on my Desktop and publish to existing. If it has been published one time it cannot be republished.  Most likely because  the path is cached incorectly in the .xml or .xsf somewhere (though I don't completely understand that).

    I have  tried both WebBased (.xsn), and Client Based (.xml) 

    I have tested both publishing over the top of the default template that is created with the Library and opening the Library with Explorer, copying the FormName.xsn into it, adjusting the Advanced Settings (template URL), Editing the newly input Template URL and publishing the Template back over the top of itself.

    This is not Application based most likely, as we are in the middle of creating a SharePoint 2013 environment and I have tested this there and it works fine (separate servers). 

    Good... Bad... Im the guy with the gun.
  • 05-16-2016 05:33 PM In reply to

    Re: InfoPath 2013 SharePoint 2010 - Network Path was Not Found

    Hi SFC_Simon,

    Sorry to hear of your problem.

    Why create the library first? Why not create it when you publish the form?

    Your method should work (since you say it has in the past) but it is not the *normal* way of publishing.

    InfoPath has to update the columns and content type when you publish over an existing library and it sounds like that is failing.

    But, if it's truly a new library, just create it on the first publish and then if you need to customize it by adding calculated columns or whatever, you can do that afterwards.

    Hope this helps, 

    Patrick Halstead
    Project Manager at Qdabra
  • 05-17-2016 06:48 AM In reply to

    Re: InfoPath 2013 SharePoint 2010 - Network Path was Not Found

    Thanks,

     I have done that as well.  I have literally tried every method for this and all result in the same error: Network Path was not found.

    For now, my only Band-Aid fix is to create library, publish once,  test, find changes, delete library, recreate library, publish, test....

    There are many methods for form creation within SharePoint.  The method I prefer to use is as follows:

    1) Create .xsn
    2) Name file (FormName_DDMMYY.xsn)
    3) Create Forms Library
    4) Open Library with explorer > open Forms Folder > Paste in .xsn
    5) Edit Library settings > Advanced settings > Change template name to match copy I pasted in
    6) Edit Form Template > Save over Top of From Template on my Desktop
    7) Publish to SharePoint (Overwriting the pasted template I created)

     This has been my method for years.  I do this so that I have a series of templates named with the date, I created them on.  This way I can fall back to templates if needed.  Or more importantly the items created in the library reference the template they were created with.  Allowing me to make changes to the template, make a new version and upload, without changing the items submitted prior. IE: Add a column, change a view, edit a form load rule, etc.. and it only effects items created from that point on.

     Either way, this is weird.  My research is now into clearing SharePoint Caches and re-running a Crawl. Because if feels as if this is related to cache.  I have already restarted the SQL Server (Fall Back to passive), cleared space on the front ends and restarted IIS.  So try 137 so to speak, lol.

    Good... Bad... Im the guy with the gun.
  • 09-14-2016 05:01 PM In reply to

    Re: InfoPath 2013 SharePoint 2010 - Network Path was Not Found

     Patrick,

    I'm having the same problem: Can't find Network after creating it from scratch. Now I'm trying to recreate the form and attach all the Data Connections to see if that works.

     

    R/

    Tonya 

Page 1 of 1 (5 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.