List Item not submitting until close of form and Workflow not triggering on new list item - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

List Item not submitting until close of form and Workflow not triggering on new list item

Last post 10-13-2015 02:20 PM by Hilary Stoupa. 9 replies.
Page 1 of 1 (10 items)
Sort Posts: Previous Next
  • 10-12-2015 01:22 PM

    • klink
    • Top 100 Contributor
    • Joined on 09-15-2014
    • Posts 99

    List Item not submitting until close of form and Workflow not triggering on new list item

    Hi, all!  I have a couple of problems. 

    I created a simple form to use as a proof of concept to do what I want, but it doesn't.  =(

    1. The form has two fields, Title and Location.
    2. User fills in fields and then clicks on Submit.  (Submit uses SubmitToSharePointList)

    This works great in Preview, but it is squirrely after I uploaded it.  When I click on the "Submit" button, it doesn't do anything until I close the form.  =(  However, it does submit to the list once I close.  WTH!

    The second problem is, once I submit the list items, it doesn't trigger my workflow on new items (or on changed items, for that matter).   

    What am I missing here?  ARGH!

    Thanks!  =) 

    Additional note:  The workflow runs when submitting from Preview mode.  =/ 

     

     

  • 10-12-2015 02:03 PM In reply to

    Re: List Item not submitting until close of form and Workflow not triggering on new list item

    Set the postback on the button to always - under the button's properties, in the browser tab.
    Hilary Stoupa

  • 10-13-2015 05:37 AM In reply to

    • klink
    • Top 100 Contributor
    • Joined on 09-15-2014
    • Posts 99

    Re: List Item not submitting until close of form and Workflow not triggering on new list item

    DOH!  Well, that worked.  However, it still doesn't kick off my workflow.  =(  Any thoughts on why that is? 

    ==================================== 

    ARGH!  Just read this:

    Just focus on two things:

    1. Workflow will never start automatically with system account.
    2. Check the options Start workflow automatically when an item is created or changed from Workflow Start Options.

    Is that true?  If so, is there a way around it?

    =====================================

    I found this:

    This sounds like the old "item created within the context of the System account doesn't fire workflow" problem.

    Run the following PowerShell script to see if the flag is set or not. If it's not set then this is very likely your problem.

    $spWebService = [Microsoft.SharePoint.Administration.SPWebService]::ContentService
    $spWebService.DeclarativeWorkflowAutoStartOnEmailEnabled

    If it's not set run this:

    $spWebService = [Microsoft.SharePoint.Administration.SPWebService]::ContentService
    $spWebService.DeclarativeWorkflowAutoStartOnEmailEnabled = $true
    $spWebService.Update()

    Don't be fooled by the name of the property...it effects any method of inserting an item into a list via the System account.

    Any risk in doing this? 

     

  • 10-13-2015 07:31 AM In reply to

    Re: List Item not submitting until close of form and Workflow not triggering on new list item

  • 10-13-2015 12:39 PM In reply to

    • klink
    • Top 100 Contributor
    • Joined on 09-15-2014
    • Posts 99

    Re: List Item not submitting until close of form and Workflow not triggering on new list item

    Darn.  Setting this did not work. 

    We did not have incoming email turned on, so we did that.  Still nothing. 

    I'm surprised this hasn't come up before.  My solution is hosed if I can't get this to work, or find a work-around.  ='( 

    Any way I can change this so the list item creator is NOT System Account? 

  • 10-13-2015 12:52 PM In reply to

    Re: List Item not submitting until close of form and Workflow not triggering on new list item

    I'd guess if you changed your list submit connection to use a UDCX and configured the UDCX to use SSO? I've emailed our support alias to ask if anyone has other ideas. I'm assuming admin approving the template won't work for you?
    Hilary Stoupa

  • 10-13-2015 01:08 PM In reply to

    • klink
    • Top 100 Contributor
    • Joined on 09-15-2014
    • Posts 99

    Re: List Item not submitting until close of form and Workflow not triggering on new list item

    Already changed list submit connection to use a UDCX, and the form template is already admin approved.  =( 

    <udc:Authentication>
       <udc:SSO AppId="InfoPath" CredentialType="NTLM"/>
    </udc:Authentication> 

    This is a claims-based site, so that is the only way to get the qRules injected form to work.  And that is what is causing the creator to be System Account.  =(   Unless I'm missing something...

  • 10-13-2015 02:04 PM In reply to

    Re: List Item not submitting until close of form and Workflow not triggering on new list item

    What's the error if you don't use UDCX?
    Hilary Stoupa

  • 10-13-2015 02:17 PM In reply to

    • klink
    • Top 100 Contributor
    • Joined on 09-15-2014
    • Posts 99

    Re: List Item not submitting until close of form and Workflow not triggering on new list item

    Don't remember exactly.  I think there is a whole post on what happens (some permissions error).  However, the point is that the person filling out the form should NOT have access to the list the form is updating, so I THINK if the creator was some account OTHER THAN System Account that has access to the list, but NOT the user filling in the form, this would work.  Is there a way to change this in the SSO (pretend I know what I am talking about... =P )?

    I will be gone tomorrow, but back bright and early on Thursday!  Any help you can give me would be appreciated immensely!

    THANKS! 

  • 10-13-2015 02:20 PM In reply to

    Re: List Item not submitting until close of form and Workflow not triggering on new list item

    Well - I guess if the SSO was set up to use the System Account (do all the list items show that as the created by?) then the SSO should be changed to a different account.
    Hilary Stoupa

Page 1 of 1 (10 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.