Data Connection will not connect to SharePoint subsite (but parent sites can be accessed!) - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Data Connection will not connect to SharePoint subsite (but parent sites can be accessed!)

Last post 05-29-2013 09:58 AM by Hilary Stoupa. 4 replies.
Page 1 of 1 (5 items)
Sort Posts: Previous Next
  • 05-28-2013 06:55 PM

    • AlexK
    • Top 150 Contributor
    • Joined on 12-31-2012
    • Posts 61

    Data Connection will not connect to SharePoint subsite (but parent sites can be accessed!)

    I'm setting up a Data Connection in my InfoPath form but it refuses to connect and show me the available lists in that site.It shows me a login prompt and all my valid logins do not work and it gives the error "Unable to connect to the SharePoint site." At the same time, I can select lists from sites directly above that one...What is going on here??

  • 05-28-2013 07:02 PM In reply to

    Re: Data Connection will not connect to SharePoint subsite (but parent sites can be accessed!)

    Hi AlexK,

    Did you check that you have enough permissions to the subsite?

    Jo-Anne Alfafara
    Qdabra® Software/ InfoPathDev.com
    The InfoPath Experts – Streamline data gathering to turn process into knowledge.™
  • 05-29-2013 09:25 AM In reply to

    • AlexK
    • Top 150 Contributor
    • Joined on 12-31-2012
    • Posts 61

    Re: Data Connection will not connect to SharePoint subsite (but parent sites can be accessed!)

    I know I have sufficient permissions for two reasons: one is because I was able to publish fine up until today, and secondly because I have admin level "full control" SP permissions on this site. It may have something to do with the Use Profile Service not working correctly though...it may be a SharePoint issue.

  • 05-29-2013 09:53 AM In reply to

    • AlexK
    • Top 150 Contributor
    • Joined on 12-31-2012
    • Posts 61

    Re: Data Connection will not connect to SharePoint subsite (but parent sites can be accessed!)

    This is definitely an InfoPath issue with data connections. ALL of my data connections are broken. I know this because creating a new data connection by going to "Add" allows me to access the site where my form was published to without any problem or any login prompts. Now I have to recreate each of them while referring to a backup. Why would InfoPath kill all of my existing data connections?

  • 05-29-2013 09:58 AM In reply to

    Re: Data Connection will not connect to SharePoint subsite (but parent sites can be accessed!)

     If it were my form, I'd save it as source files. I'd create a new form and create a list data connection to one of the same lists and save it as form files. I'd compare the data connection information in the manifest.xsf and see if I could find out what was different....

    Hilary Stoupa

Page 1 of 1 (5 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.