Problem with accessing sql table data when published. - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Problem with accessing sql table data when published.

Last post 12-22-2013 11:39 AM by rajkumar.bathula. 4 replies.
Page 1 of 1 (5 items)
Sort Posts: Previous Next
  • 05-22-2013 12:34 AM

    Problem with accessing sql table data when published.

    Hi,

    I have a really simple infopath form that has a repeating table which is populated by a single table in the database via a udc connection.

    When I  preview my form, it populates but when I publish it and I try to view it I get the below error.

    'A database that contains data required for this form to function correctly cannot be found'

    Can anybody help please :)

    Thanks.

    Jacqui.

     

  • 06-02-2013 02:14 PM In reply to

    Re: Problem with accessing sql table data when published.

    Hi Jacqui,

    The error image you attached isn't showing, but I'm guessing it's because of the credentials for the DB. Does the SQL DB live on the same physical server that is running SharePoint? If not, you may have to manually change the credentials in the UDC file.

     

    Patrick Halstead
    Project Manager at Qdabra
  • 06-04-2013 11:01 PM In reply to

    Re: Problem with accessing sql table data when published.

    Hi Patrick

    Thanks for your reply and sorry for the delay in getting back to you.

    Yes the database is on the same server as the sharepoint server.

    I have a username and password manually set in the udc which has dbo permissions on this particular database, but is that used when running the queries or do they use some sharepointuser/sharepointadmin permission.

    Thanks.
    Jacqui.

  • 06-29-2013 05:45 AM In reply to

    Re: Problem with accessing sql table data when published.

    Hi there, Finally got this solved for now, I left the connection string exactly as was in the udx file with 'integrated security=SSPI' and added my personal ad login details in the udc:authentication section. Good enough for now to get everything working then can work with ITSupport to get a user login to that database properly set up and the details in the udx file correctly. Thanks. Jacqui.
  • 12-22-2013 11:39 AM In reply to

    Re: Problem with accessing sql table data when published.

    Hi Patrick,,,,,,,,,,,,,,, I am facing a problem with the sql connection that is there in udcx and in the browser form that i published on SP 2013. The same form is working on SP 2010 :(--------------- I already posted this issue with full details here http://www.infopathdev.com/forums/p/27371/94888.aspx#94888 ------------ please have a look and kindly request you to help me.
    Thank you
    Raj
Page 1 of 1 (5 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.