Insert command for a row in a repeating table not working - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Insert command for a row in a repeating table not working

Last post 05-03-2013 12:46 PM by TomRenfro. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • 05-03-2013 12:15 PM

    • TomRenfro
    • Top 75 Contributor
      Male
    • Joined on 09-29-2011
    • Oklahoma City, OK
    • Posts 134

    Insert command for a row in a repeating table not working

    After reading several entries regarding this subject, I tried diligently to fashion my xml structure for the form where the command would insert a row into a repeating table.  The error I get is "Failed to insert the child node."

     I'm using InfoPath 2010.

    Here's the command and the screenshot of the data structure:

    Insert /parent=/my:FoundationRequest/my:Approvals/my:ApproveReject /child=my:ApprovalDisposition /count=1

    The xml structure:

     


  • 05-03-2013 12:28 PM In reply to

    • Den12
    • Top 200 Contributor
    • Joined on 01-15-2013
    • Posts 57

    Re: Insert command for a row in a repeating table not working

    There is a sibling "CurrentStatus", which is below the repeating node (ApprovalDisposition ) you are trying to insert, same parent.

    "Insert" is trying to put the new child node after "CurrentStatus" I think. Once I made the repeating group the last one in groups where regular nodes and repeating nodes exists together - no problem.

  • 05-03-2013 12:46 PM In reply to

    • TomRenfro
    • Top 75 Contributor
      Male
    • Joined on 09-29-2011
    • Oklahoma City, OK
    • Posts 134

    Re: Insert command for a row in a repeating table not working

     That was it.  Thanks.

Page 1 of 1 (3 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.