Old form locked after a new version - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Old form locked after a new version

Last post 01-11-2013 07:29 AM by Hilary Stoupa. 9 replies.
Page 1 of 1 (10 items)
Sort Posts: Previous Next
  • 01-01-2013 04:45 PM

    Old form locked after a new version

    Hi,

     I have a big problem, I have a form library with around 1000 records inside, last week I did a change in the form. After I published the newest version, no one was able to modify an existing form (not even the farm admin account). Every time, we tried to modified a record, we receive this error

    InfoPath cannot submit the form.
    An error occurred while the form was being submitted.

    The form cannot be submitted to the following location: http://sharepoint-svr/Form1/form-1.xml
    The
    filename, directory name, or volume label syntax is incorrect.

     And if we go to the property of the document and clicked Save, SharePoint return this error:

     

    Server Error in '/' Application.

     

    The file http://sharepoint-svr/Form1/Form-1.xml is check-out or lock by domain\someuser.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Runtime.InteropServices.COMException: The file http://sharepoint-svr/Form1/Form-1.xml is check-out or lock by domain\someuser.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    The only thing that seem to work is if I copy an xml to my desktop, change the solutionversion to the newest number save it back with an diffrent name. If I don't change the solutionversion and copy the file with an different name, I have the same error. 

     I even try to modified the xml form with SharePoint Designer 2007, but when I tried to save the xml file, I receive this error : Server error: L'URL "Form1/form-1.xml is invalid,

     I have place and incident issue with Microsoft and waiting... but If someone had this issue in the past and can help me I will appreciated.

     Happy new year to everyone.

    Sorry, english is not my mother tongue.

  • 01-02-2013 02:31 PM In reply to

    Re: Old form locked after a new version

    Hi guys,

     I found out that in SQL in the AllDocs table there is a columns name Dirty and all the document lock are set with 1 and the newest document are set with 0.

     Anyone knows what Dirt columns mean?

    Thanks

  • 01-02-2013 02:36 PM In reply to

    Re: Old form locked after a new version

    I'd think it means whether something has unsaved changes - is this a SharePoint SQL table?
    Hilary Stoupa

  • 01-02-2013 04:21 PM In reply to

    Re: Old form locked after a new version

    Thank you Hilary,

    Indeed, it was in the Content database, in the table called AllDocs.

    I found out that I see that other documents in that table (other library) that have the Dirty = 1 and I am able to change this document. So the Dirty column is not the problem.

     I am still waiting from Microsoft support !!!

     

     

  • 01-06-2013 02:08 PM In reply to

    Re: Old form locked after a new version

    More information .

     If we upload an new form, it works. However, with older forms when ‘solutionVersion’ is not equal to "1.0.0.938", we get the error. I tried another solutions:

    a.       I tried to copy an old form to my desktop and uploaded it to the library and that didn’t work.
    b.      I tried to change the name of the file from the desktop, then uploaded to the library. The form was copied but I cannot modify it (same error).
    c.       Then I tried to change the ‘solutionVersion’ of the form copied on my desktop. I uploaded the form with a different name and that worked.

    I really think that the ‘solutionVersion’ is the key of our problem. We cannot copy and recreate those forms because they are linked with the ID of other lists (tasks) and when we upload them with an another name, the ID is not the same.

    Regards

     

  • 01-07-2013 08:59 AM In reply to

    Re: Old form locked after a new version

    In your form template, under versioning, do you have it set to upgrade existing XML? In InfoPath 2010, that is under File --> Form Options --> Versioning...
    Hilary Stoupa

  • 01-07-2013 01:03 PM In reply to

    Re: Old form locked after a new version

    Hi Hilary,

     Yes, it is set to upgrade existing XML (Infopath 2007), but I think that we have some issue with the form services because all the old form was unchanged. But the worst part is that all old forms are now locked, I am not able to change the xml files, even with SharePoint Designer 2007. The only solution I got is to copy all form to my desktop, open the xml file and save it to my desktop. Then Remove all forms in the libarary and copy those from my desktop.

    Thank you for your help. Even Microsoft are not able to help me.

    Regards,
    Martin ROY

     

  • 01-07-2013 02:06 PM In reply to

    Re: Old form locked after a new version

    Wow - that sounds really awful. It might be worth trying (if you have not already) opening the library in Windows Explorer and copying a file out and back in - see if that does any good - and I only suggest that because I've seen it re-populate promoted properties before....
    Hilary Stoupa

  • 01-10-2013 07:27 PM In reply to

    Re: Old form locked after a new version

    Hi Hilary,

    Sorry about the delai, I was not able to copying back the file using Windows Explorer, even with SharePoint Designer. I even tried to delete a file then recovered it with the recycle bin.

     The last solution was to copying all metadata into an Excel File, Copying all form on my desktop, Modifying all Solutionversion to the newest version. Then delete all the file. Copying all the file from my desktop to the library and copy all the metadata from the Excel file. It take me 18 hours straigt to do this.

    It worked, but I have lost the created by and creation date.

    Not the best solution, but it worked.

    Thank you for your help.
    Regards,
    Martin ROY

  • 01-11-2013 07:29 AM In reply to

    Re: Old form locked after a new version

    I am so sorry this turned into such a nightmare for you. I'm glad you found a way to get things working again, and thanks for the follow up!

    Hilary Stoupa

Page 1 of 1 (10 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.