Stuck on an expression in InfoPath - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Stuck on an expression in InfoPath

Last post 09-09-2013 04:09 PM by Hilary Stoupa. 19 replies.
Page 1 of 2 (20 items) 1 2 Next >
Sort Posts: Previous Next
  • 12-11-2012 05:32 AM

    Stuck on an expression in InfoPath

    Hi, I'm used getting familiar with InfoPath and qRules and now I have come up with a problem. I'm follow the guide "Define Termsets and use qRules to load them into your form.pdf" but I get stuck at point 72, "For Value, enter For Value, enter 'Insert /parent=/my:myFields/my:TermDrilldown /child=my:TermInfo'". InfoPath says it can't find the field or location. Does anyone have a clue about what's wrong? Also, I'm fiddeling with the hierarchies for my taxonomy, problem there is that I want to specify where it should start. Right now I'm getting terms from two different groups and I only want one. For example: I only want group A to show among groups A, B, C but the taxonomy shows me all. Thanks for any piece of advice!
  • 12-11-2012 06:06 PM In reply to

    Re: Stuck on an expression in InfoPath

    Are you clicking on the fx button and entering the Insert formula in the formula editor? You don't want to do that - just enter the text in the Value box for the rule. Does that make sense?

    Hilary Stoupa

  • 12-11-2012 11:52 PM In reply to

    Re: Stuck on an expression in InfoPath

    Thanks, I noticed that yesterday as well! Do you have any idea how I can display the terms for a specific managed metadata group and not all terms from all groups? I'm trying to specify a dropdown list to only show for instance group "A"'s terms but I'm right now getting both A and B's.

    Edit: Also noticed that I can't publish the form to my Form Library. I get stuck at the Design Checker saying "Could not verify the form template on the specified server". So to sum up: - I've followed the pdf-guide completely now - The form works in InfoPath but I'm not able to publish it to my Form Library - The form only consists of the repeatable table with a dropdown. - Also, the most important part: I MUST be able to use the form as a filter. Ergo, I want to filter by metadata in a cascading dropdown list.

    Edit2: Got the form up on my Site Collection. Problem now is that when I click on the dropdown it shows no data. I published and uploaded the form to root of Site Collection and used it in a subsite if that does make any difference.

  • 12-12-2012 08:32 AM In reply to

    Re: Stuck on an expression in InfoPath

    Hi-

    If the form is not publishing directly to a form library, please check:

    (a) Are you a site collection administrator?

    (b) Is the Sandbox service running?

    You can test both of the above by publishing a sample form, with some simple code. I've attached a sample form that you could use to test.

    The other option is (of course) an issue in the form. What does Design Checker say? If you'd like, attach your form template via the Options tab.

    As far as the cascading dropdown scenario, I believe that's covered in the PDF guide.  Is that working in Preview mode in your form?

    Ernesto Machado
    Qdabra® Software/ InfoPathDev.com
    The InfoPath Experts – Streamline data gathering to turn process into knowledge.™


  • 12-12-2012 08:45 AM In reply to

    Sandbox service is probably not running. I am SC admin.

    All I get from the Design Checker is "Could not verify the form template on the specified server".

    I can view the form in the browser but the dropdown list is empty which it's not in preview mode in InfoPath. I've attached my xsn-file. Thanks for your help!

     

  • 12-12-2012 12:30 PM In reply to

    Re: Stuck on an expression in InfoPath

    Thanks.

    Could you try publishing the form I attached earlier? The error message ("Could not verify the form template on the specified server") suggests a server issue.

    I looked at Design checked locally and indeed I don't see any other messages.

    Maybe publishing the test form will give us some ideas on what may be going on. Thanks.

    Ernesto Machado
    Qdabra® Software/ InfoPathDev.com
    The InfoPath Experts – Streamline data gathering to turn process into knowledge.™


  • 12-12-2012 12:44 PM In reply to

    Re: Stuck on an expression in InfoPath

    Thanks for checking it out! I'll look into it tomorrow at work. Meanwhile, do you have any idea what could be causing the problem? Should I look at special features or services that needs to be activated? InfoPath Form Services is at least activated for sure but otherwise I'm not completely certain. I'm not the main admin for the SharePoint site. Could it depend on proxy settings or something else? Edit: The xsn you sent me, I'm getting an error that it's missing the VB or CS-file for the project. Could you perhaps send that over as well?
  • 12-13-2012 05:18 AM In reply to

    Re: Stuck on an expression in InfoPath

    You can click Ignore when prompted for the code project.

    I guess I would check whether the Sandbox service is running, which would allow you to bypass the admin deploy and instead publish directly to the form library.

    Ernesto Machado
    Qdabra® Software/ InfoPathDev.com
    The InfoPath Experts – Streamline data gathering to turn process into knowledge.™


  • 12-13-2012 07:09 AM In reply to

    Re: Stuck on an expression in InfoPath

    Well, the form didn't do much more than say "Hello there" and I hope that was correct! What now? Can you think of any reason why the form works on your server and not on mine?

    Is there any configuration settings needed to be done or something else in SharePoint, InfoPath or qRules?

     I'm getting a bit desperate here because it's getting quite urgent.

  • 12-13-2012 07:15 AM In reply to

    Re: Stuck on an expression in InfoPath

    What version of SharePoint?
    Hilary Stoupa

  • 12-13-2012 07:21 AM In reply to

    Re: Stuck on an expression in InfoPath

    2010 Enterprise

  • 12-13-2012 07:30 AM In reply to

    Re: Stuck on an expression in InfoPath

    Reviewing this thread, I think you are saying you can publish the form successfully, and open the form without a problem, but that the functionality is not working as you'd anticipate - you aren't getting any errors when you open the form in the browser?
    Hilary Stoupa

  • 12-13-2012 12:36 PM In reply to

    Re: Stuck on an expression in InfoPath

    Well, I can publish the form and open it but the dropdown list is empty which it's not in the InfoPath Preview. I'm getting no errors but as I said before. But I get a warning about the form templete on the server when I look in the design checker. No errors in the browser what so ever. What could possibly be wrong? Followed the guide numerous times exactly as stated. Also, if I can get it to work, will I be able to use the form as a filter for a list etc?
  • 12-13-2012 12:50 PM In reply to

    Re: Stuck on an expression in InfoPath

    Can you try setting postback on your dropdown control to Always? Under the control properties, on the Browser tab, set postback to Always - see what happens in the browser then. If that doesn't fix it, could you put the qRules data source Error node on your form so you'll be able to see if qRules is returning any errors?
    Hilary Stoupa

  • 12-14-2012 12:59 AM In reply to

    Re: Stuck on an expression in InfoPath

    I tried both things. My error message I get is "GetTermSets returned no result". I've tried do save my udcx-files to a data connection library, approve them.Still nothing.

Page 1 of 2 (20 items) 1 2 Next >
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.