Moving InfoPath forms from test to production - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Moving InfoPath forms from test to production

Last post 11-15-2015 09:22 AM by rajkumar.bathula. 3 replies.
Page 1 of 1 (4 items)
Sort Posts: Previous Next
  • 09-07-2012 08:56 AM

    Moving InfoPath forms from test to production

    I am using a SQL endpoint web service to connect from InfoPath several forms to a SQL database.  I developed all my forms in a test environment first and all are working well.  Now I want to move those forms into a production environment but I need to change the connection path to the production SQL endpoint so the forms will use the production SQL database.  I made sure the database has the same name as the test environment had so I would not have to change anything except the NAMESPACE in the SQL endpoint.  When I was developing the forms I know that the textboxes and values are tied to the test environment database and table columns so I was concerned about moving the forms into a production environment without having to recreate all these forms.  Is there a way to do this easily without editing all the InfoPath source files?  I tried it with one form and now I am getting errors about the template being invalid and the form can't connect to the web service.

    Thanks

    Pam Justice 

  • 09-07-2012 09:53 AM In reply to

    Re: Moving InfoPath forms from test to production

    I wish moving from a test or dev enviro to a production enviro was easier in InfoPath.

    I haven't worked with SQL endpoints in InfoPath much, but I do modify source files often for server changes. What did you change in the form where you tried this?

    Hilary Stoupa

  • 09-07-2012 10:07 AM In reply to

    Re: Moving InfoPath forms from test to production

    I opened all the source files for a form one by one and and replaced all references of "http://test/sql/endpointname?wsdl" to "http://prod/sql/endpointname?wsdl"  with notepad find-and-replace.  The manifest file also had a reference to my test sharepoint form library so I changed that to refer to the form library on my production site.  Again, I made sure that the Sharepoint form libraries are all named the same as they were on the test site so I would only have to change the references to the site.

    I then opened the manifest file in Inforpath and resaved it overwritting the existing template.xsn file and published to my production site form library.

    Thanks for any advice in advance

    Pam Justice

  • 11-15-2015 09:22 AM In reply to

    Re: Moving InfoPath forms from test to production

    Hi Hilary, you helped me a lot earlier and i wish you can help me this time too :) I am facing issues with few forms after moving all submitted forms from one site collection to another in SP 2010. Approach used: i used granular backup and restore method to move entire form library. After that many of the forms are working. Few forms are failing due to PI value that shows the URL of xsn as old site collection. I wonder how it got updated for 80% of the forms and why it didnt updated for rest of the forms. tried Solution 1: I found few blogs how to update PI info. But that method also worked for few forms only. I guess that approach is changing the schema of entire xml of few forms and so getting errors when opening form. tried solution 2: using SP object model, i am reading the form xml file to bytes and then to string array. Then i am replacing old site collection name with new. This worked perfectly in my dev box. But on production, it is adding three question marks ( ??? ) just at the begining of xml document's element. If i remoe those question marks and upload form, it works fine. I tried UTF8 format while saving back to library. still no luck tried solution 3: using relink. this is dam flaw. didnt even worked for one form. It is completely adding some wired URL instead correct URL. please advice me how i can get rid of my forms that are not working. i mean that needs to be updated with new site collection URL in PI element. thanks in advance. Raj
    Thank you
    Raj
Page 1 of 1 (4 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.