Could not verify the form template on the specified server - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Could not verify the form template on the specified server

Last post 05-12-2013 10:16 PM by frank.fajardo. 5 replies.
Page 1 of 1 (6 items)
Sort Posts: Previous Next
  • 08-15-2011 06:58 AM

    Could not verify the form template on the specified server

    I have an InfoPath form with code behind that gives me the error "Could not verify the form template on the specified server" when I run the desing checker on InfoPath. When I publish the form as an admin approved form template and try to veify it using central adminstration | Upldoad Form template, I get the error "The form template is not browser-compatible. It might be possible to correct the problem by opening the form template in Microsoft InfoPath, and then republishing it". Other forms can be verified, published and uploaded correctly.

    I have spent a lot of time investigating the SharePoint ULS logs but I cannot find a clue. What can I do to be able to upload the form template?

  • 08-29-2011 04:52 PM In reply to

    Re: Could not verify the form template on the specified server

     Hi!

    You should run the Design Checker without having InfoPath verify the form in the specified server. There's a checkbox you can uncheck.

    Unfortunately, since your form has code, the browser incompatibility could be something in your code, which is impossible for us to predict.

    Good luck!

    Ernesto Machado
    Qdabra® Software/ InfoPathDev.com
    The InfoPath Experts – Streamline data gathering to turn process into knowledge.™


  • 08-26-2012 01:23 PM In reply to

    Re: Could not verify the form template on the specified server

    Hi, I know this is an old thread,but I am encountering this same problem with my web-enabled form. My form has no code. My problem is it started to intermittently show up this error on publish. And now it just would not publish. I thought it could be linked to our sharepoint servers running on low RAM but that has now been fixed, and my problem still exists. The Design Checker does not help either as it also just tells me it could not verify the form. The form publishes but clicking the "Add new item" on IE opens up InfoPath, and on Chrome/Firefox, it comes up with a Correlation ID error. I've already tried to look into into the different XML files that make up the .XSN (eg, manifest.xsf). I originally copied this form from another similar, as I did not want to redo some logic from the other form which I also need on this new form. And I have diligently remove rules and fields I do not need. I can see in the Rule Inspector and even in the manifest.xsf that all appears good. (Except the Rule Inspector does not seem to like double evals for some reason--but I kept it since they work on the original form that I copied from). Could anyone help. I've been working on this form for weeks trying to fix it and I'm at the end of my wits. Thanks in advance.
  • 08-26-2012 01:33 PM In reply to

    Re: Could not verify the form template on the specified server

    I forgot to say, I'm using InfoPath 2010 and publishing to Sharepoint 2010 forms site.
  • 08-27-2012 03:18 AM In reply to

    Re: Could not verify the form template on the specified server

    frank.fajardo:
    Hi,

    I know this is an old thread,but I am encountering this same problem with my web-enabled form. My form has no code.

    My problem is it started to intermittently show up this error on publish. And now it just would not publish. I thought it could be linked to our sharepoint servers running on low RAM but that has now been fixed, and my problem still exists. The Design Checker does not help either as it also just tells me it could not verify the form.

    The form publishes but clicking the "Add new item" on IE opens up InfoPath, and on Chrome/Firefox, it comes up with a Correlation ID error

     

    Have I understood correctly that the problem comes up only from browsers which are not IE?

    Gennady Vanin (Novosibirsk) --- Геннадий Ванин (Новосибирск)
  • 05-12-2013 10:16 PM In reply to

    Re: Could not verify the form template on the specified server

    Hi Gennady, No, the error happens when I'm publishing the form. It publishes the form but Infopath comes back with "Unable to verify". And the form becomes inaccessible from the browser, regardless of which browser is used. Somehow, it appears that if I reduce the amount of conditional sections on my form, it works. I have not worked out the limit on the conditions, as it seems to to invariably like and dislike my form.
Page 1 of 1 (6 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.