Adding a button - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Adding a button

Last post 10-19-2010 01:37 AM by jaybranch. 4 replies.
Page 1 of 1 (5 items)
Sort Posts: Previous Next
  • 10-18-2010 03:23 AM

    Adding a button

    Hi all,

     Ok, we have our InfoPath forms... one for a holiday request and another for a Purchase Order request.  What we are looking to do, to make it easier for the users is to create 2 buttons on the page, one for each form.

    So, we created two buttons using Sharepoint designer, one for each form.  When we click the button, it asks if we want to open the form (which doesn't happen when we use the New > Form option, it just loads the form without asking any questions.......  ??) then stops with this error:

    "The form you have opened requires Domain level access for it work"

    However, the form already has this access....

    Can anyone suggest a way that we can use to get this to work??

     

    Thanks all!

     

    Filed under: , ,
  • 10-18-2010 05:13 AM In reply to

     Hi, you probably need to change your level restrition, on designe mode, go on tools, form option, security and trust, and set your permission to Domain.After that republish your form....

  • 10-18-2010 08:39 AM In reply to

    Thanks for the reply....  I checked this and it seems to be already set to 'Domain'

    However, the difference between the buttons we created and the 'New' button on the toolbar is that when we click the button (Which we linked to the template.xsn file) it asks to open the file and then the error shows up... 

    If we simply click the 'New' button instead, the site opens up the xsn file directly with no error!!

    *confused*

  • 10-18-2010 09:57 AM In reply to

    Your Sharepoint site is on your local intranet on IE Internet security ?

  • 10-19-2010 01:37 AM In reply to

    I solved it....  however, it wasn't a perfect fix!

    Basically, the type of button I had added to the page (using Sharepoint Designer) was a standard button with a PostBackURL that I used to point to the URL of the template .XSN file.

    However, when I tried to open this, it didn't work! 

    But, when I just used a hyperlink instead of a button (and then made the appearance of the hyperlink look like a button) it worked.   The hyperlink includes a "NavigateURL" in the tag properties, which I amended to the location of the .xsn file...  it now takes me straight to the form and opens it without any errors

    Not perfect... but it works!

    Thanks for your suggestions 

    Jay

Page 1 of 1 (5 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.