InfoPath 2007 Form Submit to SQL Server Fails - InfoPath Dev

InfoPath Dev

Use our Google Custom Search for best site search results.

InfoPath 2007 Form Submit to SQL Server Fails

Last post 06-30-2010 12:45 PM by InfoJunkie. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • 06-22-2010 05:42 PM

    InfoPath 2007 Form Submit to SQL Server Fails

    I created a test database on my SQL server. It has one table with two fields - a "unique record ID" and a field called "Name". Then I setup a new InfoPath form based on the database. It does allow the Submit option. I dragged the name field to my form, previewed the form, entered a name and tried to submit it. It failed giving me this error message:  

    InfoPath cannot connect to the data source.
    Access is denied.
    Access is denied.

    I log in to the SQL server with SQL Server Authentication using the administrator's ID and Password. As best I can tell the connection is working fine. What should I look for to solve this?


  • 06-28-2010 10:46 PM In reply to

    Re: InfoPath 2007 Form Submit to SQL Server Fails

    Hi and welcome to our forums!

    Have you tried using a different group account or individual access with select/write access to the database table? Also, is the database in the same domain? It could be a trust issue.

    Jo-Anne Alfafara
    Qdabra® Software/
    The InfoPath Experts – Streamline data gathering to turn process into knowledge.™
  • 06-30-2010 12:45 PM In reply to

    Re: InfoPath 2007 Form Submit to SQL Server Fails

    Thanks for your reply Jo-Anne. To simplify the environment, I made up a simple Access database on my computer with one table and two fields. Then I made up an InfoPath form to work with it. When submitting a record I got the same “Access Denied” error. Searching the internet for a solution, it seems that changing the security (under form options) to full trust would fix this. So I tried it and was able to submit records to the Access database. Going back to my SQL Server InfoPath document, I changed the security to Full Trust and can submit the record. I can’t save the document with Full Trust selected because it won’t let me open it (needs a certificate??). So for now I have to switch each document to Full Trust in order to submit them.


    The document I’m creating has 5 pages with almost 700 fields – many check boxes. I completed the first page and can submit it (using Full Trust) with no problems. I added the rest of the fields to the SQL Server table and worked on the second page. Trying to submit (using Full Trust) I am getting this error:

     Attribute 'c307' is not allowed on element '{}AdmissionRecords', according to Schema. 

    So I’m wrestling with two problems in getting this document to work. I’d like to avoid the step that requires me to change the security setting for each submission, and this Attribute problem.


    Do you have any suggestions?


    Thanks Jo-Anne.


Page 1 of 1 (3 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.