Is qRules compatible with InfoPath 2003? - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Is qRules compatible with InfoPath 2003?

Last post 11-25-2009 11:28 AM by SamCamblin. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • 11-25-2009 07:22 AM

    Is qRules compatible with InfoPath 2003?

    I’m using qRules v1.7 and InfoPath 2007 to work on my form.  Specifically I’m using the “Insert” command for a button on my form.  Everything works fine in InfoPath 2007.  I’ve been informed that a client will be using InfoPath 2003.  When I click “Show report on compatibility with InfoPath 2003” on the form options menu, I see an error in the design checker.  The error says: “Code language and/or OM version is not supported”.  

    I’m trying to troubleshoot what’s causing the error message.  I added code (Alt + SHIFT + F12).  Then I clicked “remove code” in Form Options and the error disappeared.  When I re-injected qRules the error reappeared.   Is qRules causing this error message?  Please advise.   

     

  • 11-25-2009 07:27 AM In reply to

    Re: Is qRules compatible with InfoPath 2003?

    Hi Sam. Yes, qRules is only compatible with InfoPath 2007 forms.

    Ernesto Machado
    Qdabra® Software/ InfoPathDev.com
    The InfoPath Experts – Streamline data gathering to turn process into knowledge.™


  • 11-25-2009 11:28 AM In reply to

    Re: Is qRules compatible with InfoPath 2003?

    Below is an example for C# (compatible with 2003).  Here I'm adding a row and switching views.  Attached is my InfoPath form.

     

    thisXDocument.View.ExecuteAction("xCollection::insert", "group2_1"); //

    thisXDocument.View.SwitchView("View 2"); //switch view

     

Page 1 of 1 (3 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.