An error occurred accessing a data source. Log ID:5566. - InfoPath Dev

InfoPath Dev

Use our Google Custom Search for best site search results.

An error occurred accessing a data source. Log ID:5566.

Last post 01-10-2011 11:34 AM by BarryT1590. 4 replies.
Page 1 of 1 (5 items)
Sort Posts: Previous Next
  • 10-05-2009 11:04 PM

    • rom@n
    • Not Ranked
    • Joined on 08-19-2009
    • Posts 10

    An error occurred accessing a data source. Log ID:5566.


    Here is my situation. I have an infopath form with several data connections. Some of them are pulling data from static XML files, the others are pulling from SharePoint lists. There is one SharePoin list with product names in it, which I'm using to populate a dropdown list in the form. The list sorts the product names according to ID, not alphabetically by name. As you know, InfoPath does not pull it to dropdown list in alphabetically sorted order. You have to do this by managed code or by defining a view in the SharePoint list and making xml query URL with list and view GUIDs to pull data from the list. I was trying to implement the latter one based on this -


    So, I made above query URL and used it as data connection instead the one I had for pulling product names from the list. It worked fine when I open the form in InfoPath. But, when I published it on server and accessed it from web browser, I got below common and general error. I looked for solution in many places, but nothing worked for me till now. I know one thing, if I use data connection that directly accesses the same list, it works fine. Also, I don't use anonymous access either in SharePoint or IIS. I would try managed code way, but I don't want to change trust settings and change the way it is deployed to the server.

    There has been an error while processing the form.
    Click Continue to resume filling out the form. You may want to check your form data for errors.

    Click Start Over to load a new copy of the form.

    Log id 5566.




  • 10-14-2009 05:08 AM In reply to

    Re: An error occurred accessing a data source. Log ID:5566.

    While I don't have an exact answer for your scenario, I can tell you that I've seen this message when dealing with sharepoint permissions.For example, the InfoPath form has a dropdown that pulls values from a sharepoint list. I don't have permissions to that sharepoint list, so I get this error when opening the form in the browser.

    Though it works for you in preview (e.g. you are authorized to execute your own code on your local machine), I would suggest that you change the form library settings to force the form to open in InfoPath instead of the browser, then try to open it from the form library. Perhaps the error message there will be more informative and tell you what is the permissions error related to your code.

    Good luck.

    Ernesto Machado
    Qdabra® Software/
    The InfoPath Experts – Streamline data gathering to turn process into knowledge.™

  • 10-14-2009 07:24 AM In reply to

    • rom@n
    • Not Ranked
    • Joined on 08-19-2009
    • Posts 10

    Re: An error occurred accessing a data source. Log ID:5566.

    Hello ErnestoM,

    Thank you for your reply. I did like you said, forced it to open in InfoPath. And now I have more detailed error here. Frankly, I don't quite understand what permission it requires. I'm publishing the form using sysadmin account, and I'm trying to open it using sysadmin account too. This account has most full rights/permissions.

    The form cannot be opened because it requires the domain permission level and it currently has restricted permission. To fix this problem, open the form from the location it was published to. Forms that require the domain permission level contain features that access information on a network, such as data connections, linked images, and code.

    It is strange because I made a single change, which is I used dynamic XML Data Connection (http://portal/_vti_bin/owssvr.dll?Cmd=Display&List={ListGuid}&View={ViewGuid}&XMLDATA=TRUE) instead of static one (simple SharePoint list Data Connection) that I had before. They are both pulling from the same list.

    Well, I think there should be an easy solution, as the form opens in Preview without problem, but I feel like I cannot handle this one without your help. Please help me if you know what else I could do to try to resolve it.

    Thank you!

  • 08-17-2010 05:19 AM In reply to

    • s42bm
    • Top 500 Contributor
    • Joined on 04-21-2008
    • Posts 32

    Re: An error occurred accessing a data source. Log ID:5566.

    Hi rom@n, Just wondering if you solved your problem? I'm having the same problem as you did, could you please let me know if you have the answer? Thanks!
  • 01-10-2011 11:34 AM In reply to

    Re: An error occurred accessing a data source. Log ID:5566.

    This is normally seen when the logged-in user does not have aceess to a secondary datasource. Open Infopath and view the Data Source tab make sure the user has permissions to all of the data sources in the drop-down box.


Page 1 of 1 (5 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.