Sharepoint workflow doesn't show all Infopath promoted fields - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Sharepoint workflow doesn't show all Infopath promoted fields

Last post 03-11-2019 07:35 PM by zakaria.botros. 22 replies.
Page 2 of 2 (23 items) < Previous 1 2
Sort Posts: Previous Next
  • 09-04-2009 05:06 AM In reply to

    Re: Sharepoint workflow doesn't show all Infopath promoted fields

    @Qazi Anis: it's all a matter of knowing. I've managed to upload the picture now.


  • 09-04-2009 05:19 AM In reply to

    Re: Sharepoint workflow doesn't show all Infopath promoted fields

    @ Princevis: As far as I can see I can only publish directly into the DocLib. I don't get an option to choose to publish through Central admin. Where could I find this?

     Regarding a possible incompatibility between Sharepoint designer 2007 and InfoPath2003: I'll try to download a testversion of IP 2007 and see whether it makes any difference.

  • 09-04-2009 05:39 AM In reply to

    Re: Sharepoint workflow doesn't show all Infopath promoted fields

    Follow these steps::- 1st publish form to a local location,say My Documents,make sure b4 that u'll click on option of enable infopath to open in browser,and change security level to full trust,in form options.

    Then keep clicking on next,add fields that you want to make visible in form library,and finish the publishing wizard.

    Next goto Central admin,and enable infopath form services,in central admin->Application Management->Infopath forms services,click on upload Form template.

    select the location of your infopath form locally and click on upload.

    Next goto manage form template,just below Upload form template in infopath form services,select your infopath form and activate it to a Site collection where you want to use it.

    Goto ur site,create a form library,and goto advanced settings of ur form library,and select allow management of content types and display as web page.

    Then from upload existing content,select the form that you just activated for that site collection..make it default and try to run ur workflow.I think now u won't have problem in making the fields editable..

    i would be glad to hear,if that works,otherwise we'll proceed further and try to make it work 4 u anyways,4 the time being try this and let me know.Have a good day

     

    Vishal Srivastava
    Senior Software Engineer
    SDG Software Pvt Ltd
  • 09-04-2009 06:08 AM In reply to

    Re: Sharepoint workflow doesn't show all Infopath promoted fields

    Thanks for this extensive guideline. I 'm still struggling with what you call Central Admin and enabling infopath form services. Where do I find Central Admin? Is it a setting in InfoPath, in Sharepoint Designer, Is it a setting on the server where the sharepoint sites are located, ...?

    Appologies if my questions sound stupid, but as I told before, I'm just starting to work with this.

     Thanks already for the time you're spending with me.

  • 09-04-2009 06:16 AM In reply to

    Re: Sharepoint workflow doesn't show all Infopath promoted fields

    I think u have MOSS 2007 installed on your server..An you are working on windows server 2003 as OS.

    If this is fine,goto start menu->locate Microsoft Office Server-> and find Central Administrator..

    Let me know if u r able to locate that..

    Vishal Srivastava
    Senior Software Engineer
    SDG Software Pvt Ltd
  • 09-04-2009 06:46 AM In reply to

    Re: Sharepoint workflow doesn't show all Infopath promoted fields

    Oops, that's going to be a difficult one: this server is not in our hands... and we don't have access to that.

    But we will try it on a test server where we do have access. If this is indeed the solution we will know what we will have to ask for to the central IT department.

     Information about the test with a trial version of InfoPath 2003: I had it installed but it's not possible to publish with this trial version... Bad luck.

     I'll come back when we have done the test with the test server.

    Thanks again for staying with me.

  • 09-16-2009 07:29 AM In reply to

    Re: Sharepoint workflow doesn't show all Infopath promoted fields

    Sorry for keeping you all waiting for so long but we had some other priorities in between.

    Here's where we are: we have tried the steps that were suggested by Princevis, but it didn't make any difference. Too bad.

    But I have tested with a full copy of InfoPath 2007 and then it works. So, our workaround is to design the forms with IP 2007, publish them and create the workflow (the fields are visible). What we found is that the other users can use their version of InfoPath 2003 normally. So we only need to have a restricted number of IP 2007 licences.

     Thanks again for all your help.

  • 03-11-2019 07:35 PM In reply to

    Re: Sharepoint workflow doesn't show all Infopath promoted fields

    Hello Guys, I Have the same problem. I'm using InfoPath 2003 and SP designer 2003, with Sp web 2013. I did promote many fields from the form to SP form Library and I can see them as columns. but in set field action in the workflow, I cannot see the fields that I want to modify. only what I can see is Item, name only. Any news or updates?
Page 2 of 2 (23 items) < Previous 1 2
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.