Authentication Issues - InfoPath Dev

InfoPath Dev

Use our Google Custom Search for best site search results.

Authentication Issues

Last post 09-10-2008 02:09 PM by Tamarack. 0 replies.
Page 1 of 1 (1 items)
Sort Posts: Previous Next
  • 09-10-2008 02:09 PM

    Authentication Issues

    Normal 0 false false false EN-US X-NONE X-NONE MicrosoftInternetExplorer4 /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin;}

    I am having trouble with an InfoPath form that I created, more specifically the authentication between the form and the SQL database. 


    I published my file to a network folder that some of our basic users can access.  When I logged into a basic user's computer with their credentials and tried to query on the form (using their credentials) it asks which database I wanted to connect to (which typically doesn't happen) and then it asked if I wanted to Use a trusted connection or other credentials.  I tried both and got an error message:


    Connection Failed:

    SQLState: ‘42000'

    SQL Server Error : 18456

    Login Failed for user ‘xxx' 


    So one might conclude that the basic user doesn't have the right credentials to access the database right?  Well then I unchecked the box "Use Trusted Connection" and put my own info in the blanks.  I am both a system admin in SQL and on the Network.  I still received the same error.  Now when I log the user off and log in as myself, then run the form, I get no problems.  When I looked in the event viewer on the Server I saw that the Severity was 14 and State either equaled 5 or 11.


    Any thoughts?

Page 1 of 1 (1 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.