SubmittoSharePointList data from InfoPath form parameter not rendering in Sharepoint List - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

SubmittoSharePointList data from InfoPath form parameter not rendering in Sharepoint List

Last post 08-19-2021 09:13 AM by T Johnson. 8 replies.
Page 1 of 1 (9 items)
Sort Posts: Previous Next
  • 08-18-2021 12:25 PM

    SubmittoSharePointList data from InfoPath form parameter not rendering in Sharepoint List

    I worked through qRules and the SubmittoSharepoint tool to develop a form with a repeating table. I am currently waiting on admin approval for my form template so it is not published yet, but the data is successfully linked to a SharePoint list. However, the first field/question (drop-down) in my form is not appropriately rendering to the SharePoint list. I thought there could be an issue with my mapping and the way I set the column up, but i have another drop down that is embedded in a repeating table that is working perfectly fine. I am looking for a way to make sure that the data from the "EmployeeType" field is appropriately pushing to my list. Also, I am looking for clarification on how to map two or more repeating tables in one form to the same sharepoint list. I am unsure how to make the tables relative to one another so that the data is saved appropriately. I solved this problem, by combining my two desired repeating tables into one with a drop down field, but I am curious of the actual solution. I have attached my mapping and form. I have also included a screenshot of my schema for quick review.
  • 08-18-2021 12:27 PM In reply to

    Re: SubmittoSharePointList data from InfoPath form parameter not rendering in Sharepoint List

    Including schema picture and mapping.
  • 08-18-2021 04:44 PM In reply to

    Re: SubmittoSharePointList data from InfoPath form parameter not rendering in Sharepoint List

    Are any of your non-repeating fields getting saved to the list? I think the relative paths may be off by one - you have ../../../../../my:FOD and I think it is supposed to be relative to group17, so would be ../../../../my:FOD for example. If you need to map multiple repeating groups to the same list, just add another mapping - not as a child in the mapping tool, but it can be in the same file. You can have multiple mappings to the same list (I think - if the mapping tool blocks that for some reason, just use separate mapping files and the /mapping parameter)
    Hilary Stoupa

  • 08-19-2021 05:01 AM In reply to

    Re: SubmittoSharePointList data from InfoPath form parameter not rendering in Sharepoint List

    Hmm, I will attempt adjusting that however every other field is mapping properly, including when multiple lines from the repeating table are entered, so I am not sure that will resolve my issue. Is there anything else that could have led to this issue? Also, in this secondary mapping do i remap everything again but relative to the other repeating group and this way they can properly relate to one another?
  • 08-19-2021 08:25 AM In reply to

    Re: SubmittoSharePointList data from InfoPath form parameter not rendering in Sharepoint List

    So your other higher level fields are submitting data to the list? Just Employee Type is not?
    Hilary Stoupa

  • 08-19-2021 08:39 AM In reply to

    Re: SubmittoSharePointList data from InfoPath form parameter not rendering in Sharepoint List

    Yes, Employee Type is the only field not working properly.
  • 08-19-2021 08:46 AM In reply to

    Re: SubmittoSharePointList data from InfoPath form parameter not rendering in Sharepoint List

    And just to make sure I understand - when you say "not working properly" you mean the data isn't submitted to the list? That column is blank?
    Hilary Stoupa

  • 08-19-2021 08:52 AM In reply to

    Re: SubmittoSharePointList data from InfoPath form parameter not rendering in Sharepoint List

    So - if I put a calculated value into group17, which is the base path for your mapping, and select Employee Type, the XPath is: ../../../../my:EmployeeType which is why I think the relative paths to your non-repeating data may not be correct. Here's a copy of your mapping with the non-repeating fields changed, perhaps you could give it a try.
    Hilary Stoupa

  • 08-19-2021 09:13 AM In reply to

    Re: SubmittoSharePointList data from InfoPath form parameter not rendering in Sharepoint List

    Thanks alot, Hilary. It seems that was the issue, but for some reason it only affected the 'Employee Type' field. All is resolved now.
Page 1 of 1 (9 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.