SubmitToSharepointList is not adding a new item when running in a control rule - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

SubmitToSharepointList is not adding a new item when running in a control rule

Last post 10-17-2014 08:19 AM by dabramov. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • 10-16-2014 03:57 PM

    SubmitToSharepointList is not adding a new item when running in a control rule

     Hi,

    I have a form that based on a selection in a MSLB, build a text string control with all ID´s checked. This control has a rule that recovers each ID, read an information from a Reseller list and build a new content that is going to be submitted to another list named Cancel-Request.

    Everything works fine if I select just one item from the MSLB, if I select more than one I can submit the first item, after that the ID of the Cancel-Request list is not incremented and instead of add a new item the process is updating the previous one.

    Any help ?

    Best regards,

    Dinis

       

    Filed under:
  • 10-16-2014 05:56 PM In reply to

    Re: SubmitToSharepointList is not adding a new item when running in a control rule

    You don't need to include the /id parameter in your command for versions of qRules later than 4.2 - that is now info in the mapping file.

    Are you wanting to submit new items to the list each time the rules fire on control where you are storing all the ID's? I think at some point, you may get an error about the number of calc's exceeding IP's limit, since you are changing the field the rule is firing on.

    Right now, the Id field is getting set with the Id for the first item submitted. So, the additional submits will update that item, as you've found. I think you should remove the Id from the mapping:

        <Mapping>
          <FormField IsRichText="false" IsId="true" IsAttachment="false">my:meusCampos/my:Id</FormField>
          <SharePointColumn />
        </Mapping>

    If you keep the Id in the mapping (perhaps you intend to record it someplace else?) you need to clear it prior to the next submit.

    Hilary Stoupa

  • 10-17-2014 08:19 AM In reply to

    Re: SubmitToSharepointList is not adding a new item when running in a control rule

     Hi Hilary,

     Thanks for your prompt answer.

     Just to clarify: Initially I was not including ID parameter in the command, it was trial to resolve the issue.

     I did test both ways you suggested and both worked fine. I have decided to remove ID from the mapping.

     

    I appreciatte so much your support.

    Dinis 

       

    Filed under:
Page 1 of 1 (3 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.