Q rules GetUserByName causes infopath to crash when linked to a default value. - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Q rules GetUserByName causes infopath to crash when linked to a default value.

Last post 06-12-2014 11:29 AM by ErnestoM. 3 replies.
Page 1 of 1 (4 items)
Sort Posts: Previous Next
  • 06-11-2014 04:41 AM

    Q rules GetUserByName causes infopath to crash when linked to a default value.

    Hi,

    I am using SharePoint 2010 and InfoPath 2010.  I have created a test form injected with q-rules 5.1.

    I have a people picker on the form and a field called AccountIDLookup - nothing else.

    I have a rule on AccountIDLookup which sets the command field in q-rules to be concat("GetUserProfileByName /user=", .)

    When I select from the people picker and manually copy the Account id from the people picker fields into AccountIDLookup - it sets the GetUserProfilebyName property data correctly.

    If I set the DEFAULT value of AccountIDLookup to be the Account id field from the people picker and run the form again InfoPath crashes - Microsoft InfoPath has stopped working.

    I am running the form in preview.  I have looked at Fiddler - Error line and Text view of the error line shown below signature.

    This is a brand new form - but the reason I have started investigating this is that existing forms - forms which have been working fine have started exhibiting the same error in preview.  (The most important of which is a live Equipment Request form which Jimmy developed for me and has been working absolutely fine for the last 6 months.)    Even versions of the form which are 4-5months old - and were working have crashed when previewed.  I don't really know what to do next.   

    Is this indicating a change in our environment ? - Where can I start looking ?  I cannot do any more "tweaks" to forms which use this strategy - because I have no confidence that they will work when deployed.

    Thanks - Catharine

     GET /StageOne/INFOPATH_EXE/14_0_7010_1000/512259fc/ContactPicker_dll/14_0_7010_1000/511cff94/c0000005/00013240.htm?LCID=1033&skulcid=1033&LCID=2057&OS=6.1.7601.2.00010100.1.0.4.17514&SM=Dell%20Inc.&SPN=Latitude%20E6320&BV=A14&MID=E9A9AF7B-1BEA-4E0E-BD1D-1EE347199D2C&HCU=696 HTTP/1.1

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

    <html xmlns="http://www.w3.org/1999/xhtml">

    <head>

    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>

    <title>404 - File or directory not found.</title>

    <style type="text/css">

    <!--

    body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;}

    fieldset{padding:0 15px 10px 15px;}

    h1{font-size:2.4em;margin:0;color:#FFF;}

    h2{font-size:1.7em;margin:0;color:#CC0000;}

    h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;}

    #header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;

    background-color:#555555;}

    #content{margin:0 0 0 2%;position:relative;}

    .content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;}

    -->

    </style>

    </head>

    <body>

    <div id="header"><h1>Server Error</h1></div>

    <div id="content">

    <div class="content-container"><fieldset>

    <h2>404 - File or directory not found.</h2>

    <h3>The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.</h3>

    </fieldset></div>

    </div>

    </body>

    </html>

  • 06-11-2014 08:20 AM In reply to

    Re: Q rules GetUserByName causes infopath to crash when linked to a default value.

    Hi - are you able to see if the forms also crash in preview on a different machine? Is this only occurring in preview, not when actually using the form? Thanks!

    Hilary Stoupa

  • 06-11-2014 08:46 AM In reply to

    Re: Q rules GetUserByName causes infopath to crash when linked to a default value.

    Hi Hilary

    I have sent it to my colleague and run from her machine - in preview and it crashed.

    I have run from a virtual machine and it crashed.

    I have published it to the server and run from a form library and it crashed.

    Thank you.

  • 06-12-2014 11:29 AM In reply to

    Re: Q rules GetUserByName causes infopath to crash when linked to a default value.

    Thank you for reporting this. qRules v6.1 will be updated to fix this issue.

    Ernesto Machado
    Qdabra® Software/ InfoPathDev.com
    The InfoPath Experts – Streamline data gathering to turn process into knowledge.™


Page 1 of 1 (4 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.