IP07 Email layout messed up. - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

IP07 Email layout messed up.

Last post 06-21-2013 07:16 AM by wilkies0106aw. 5 replies.
Page 1 of 1 (6 items)
Sort Posts: Previous Next
  • 06-21-2013 03:04 AM

    IP07 Email layout messed up.

    Hey,

    When using a button with submit to email function, the email layout looks absolutely terrible, while the form looks great while viewing it through a website or in InfoPath.

    Here's what it looks like in Preview.

    Preview Layout

    And here we have it in the email.

    Email

     I've googled like crazy, but I can't seem to find anything that helps.

    I've checked all the "Width" attributes on the Controls, and nothing is set to 100% anymore, I've changed it to a static pixel width. Some reported that this fixed the issue, but it didn't for me.

     What do I do?

    Filed under:
  • 06-21-2013 06:19 AM In reply to

    Re: IP07 Email layout messed up.

    For me I'd do the following.

    Create a table 1 row wide (Insert>Custom Table) to the full width measurement that you want the completed form to be.

    Then split the row into 2.  (Table Tools>Split Cells>2).  Then one column is for your label i.e. Last working date and the other column is for your data i.e. 21/06/2013

     You could drag your fields to the rows for you and it would do most of the work.

     Just add new rows as required i.e.right click on a row>Insert Row Below.

     

  • 06-21-2013 06:19 AM In reply to

    Re: IP07 Email layout messed up.

    Hi-

    We recently discussed a similar question here:

    http://www.infopathdev.com/forums/t/26016.aspx

    Could you check if the advice there helps?

     Thanks!

    Ernesto Machado
    Qdabra® Software/ InfoPathDev.com
    The InfoPath Experts – Streamline data gathering to turn process into knowledge.™


  • 06-21-2013 06:34 AM In reply to

    Re: IP07 Email layout messed up.

    Hey again guys,

    Thanks for the pointers, but I think I'm pretty screwed after reading what you wrote.
    I'm a completely newbie when it comes to InfoPath, so this form was created in one big Cell.
    Might be the reason why it gets messed up.

    Anyways, I decided to re-create it.
    This time, more clean and nice, one cell per control etc.
    Either way, I've run into an issue.
    I want to set conditional formatting on a Group which contains 2 controls.
    But I can't figure out how to do it.
    When right-click the group, and checking the properties, the Validation tab is greyed out.
    What I wanna do is "If ControlX equals 1234 HIDE GroupX"

    Am I missing something obvious here?

    Greyed Out

  • 06-21-2013 07:15 AM In reply to

    Re: IP07 Email layout messed up.

    I use IP 2010, 07. Yet your issue looks like the following:

    Try Try to write the condition formatting rule against the control not the group. Alternatively you'll have to add a section, then put your controls into that section. Write your rule against the section.

  • 06-21-2013 07:16 AM In reply to

    Re: IP07 Email layout messed up.

     This might help you - http://amalnagm.wordpress.com/2009/02/26/insert-a-section-infopath-2007/

Page 1 of 1 (6 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.