login prompt for web service - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

login prompt for web service

Last post 08-26-2015 11:02 PM by bradleyl. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • 05-04-2012 12:01 PM

    login prompt for web service

    hello

      I have a InfoPath 2007 form used with SharePoint 2007 (MOSS).. I have 1 user, yes only 1, that when they open the form they get prompted for credentials when trying to load initial data connections.

    The box says: "Enter your credentials to connect to the following Web service:".. The web service listed is the lists.asmx for SharePoint.. Yes 3 of the several data connections are SharePoint, but none of them are setup as web service connections just normal SharePoitn connections.. I can easily beleive that Infopath is talking to SharePoint via it's web services.. I am stumped on this one though becuase no matter what they enter it never works, the data never gets loaded.. I have checked internet explorer zone settings and they match mine perfectly.. Please help!!!

  • 06-19-2013 06:51 AM In reply to

    Re: login prompt for web service

    I am having the same exact issue and can't find a fix anywhere.  Users are trying to open a form that has been in use without issue now for several months.  Suddenly yesterday, when they open the form, it tells them they are working offline and then if you click the button to connect, it prompts them to enter their credentials to connect to the web service _vti_bin/Lists. No matter what they enter, it doesn't connect.  However, if I access the same forms, everything connects successfully and I have the farm account.

    Does anyone know why this is happening and how I can fix it?  it is causing a lot of issues.

  • 08-26-2015 11:02 PM In reply to

    • bradleyl
    • Not Ranked
    • Joined on 08-26-2015
    • Brisbane
    • Posts 1

    Re: login prompt for web service

    We have come across this same issue.

    This was the permissions to certain Sharepoint lists that were used as seondary data connections, for drop down lists, in the form.

    If your form connects on opening to these data connections, then all the people that use the form must have read access to those Sharepoint lists. Otherwise, they get prompted for their credentials to get access.

    The issue occurred for us when someone had hanged the permissions on one of these lists to remove the access for various people, and suddenly the Form now asked them for "Enter your credentials to connect to ..."

    Two solutions
    1) - grant these people access to those lists
    2) - In Infopath, only use that data connection when you KNOW that the user should have access to the list, based on a condition in your rule

    Leo

    Leo Bradley, SharePoint Analyst, Business Solutions
    Information and Technology Partners
    Brisbane
Page 1 of 1 (3 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.