Infopath script error with conditionally formatted section and rich text in a seperate repeating section - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Infopath script error with conditionally formatted section and rich text in a seperate repeating section

Last post 02-06-2012 11:47 PM by Anson Hidajat. 1 replies.
Page 1 of 1 (2 items)
Sort Posts: Previous Next
  • 02-02-2012 09:36 AM

    Infopath script error with conditionally formatted section and rich text in a seperate repeating section

    Hi,

    I have run into a javascript error in Infopath Form Services on Sharepoint 2010 whenever I am using a conditionally hidden section, and I have a repeating section with Rich Text Fields somewhere else in the form. The section is hidden based on the value of a Boolean field in the form. When the value of the field is updated by a button that is inside the section, I get a core.js error, and most of the values in the Rich Text Fields "disappear" from the screen.  However, If the Boolean field is updated using a button that is outside the section, then everything works fine.  Any actions that causes another postback/refresh after the error has occurred will cause the data that was in the rich text fields to "reappear" again (provided that they don't generate any errors themselves).

    Here is the error as it appears in the Console in IE9:

    SCRIPT5007: Unable to get value of the property 'className': object is null or undefined
    Core.js?rev=CDC6FnRltcUVym10Zx1m2g%3D%3D, line 2 character 294686

    This is using Sharepoint 2010 with the December 2011 CU installed, with the form open in IE9. I've create a template that exhbits this behavior and attached to this post for reference.

    Is this a bug in InfoPath Form Services... or am I doing something wrong?

    Let me know if I can clarify anything if this doesn't make sense. Thanks.

     

     

  • 02-06-2012 11:47 PM In reply to

    Re: Infopath script error with conditionally formatted section and rich text in a seperate repeating section

    Did you hand modify the XSN of this form?  If so, that might be the causing the null object error.  Otherwise, you might have hit a bug.  As a workaround, I would try deleting the controls, fields, and rules then reinserting them into your form to see if that fixes the problem.
    Anson Hidajat
    Qdabra® Software/ InfoPathDev.com
    The InfoPath Experts – Streamline data gathering to turn process into knowledge.™

Page 1 of 1 (2 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.