Rule Validation not working for drop-down list - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Rule Validation not working for drop-down list

Last post 11-14-2010 09:42 AM by john2010. 1 replies.
Page 1 of 1 (2 items)
Sort Posts: Previous Next
  • 11-11-2010 10:12 AM

    Rule Validation not working for drop-down list

    I can't get a simple rule validation to work.

    I'm checking a field to see if it is greater than 0, if it is greater than zero than a value has to be populated from the drop down list.

    The behavior is that when the field is > 0 than the drop-list shows an "*" so that a selection is required - that part works correctly.

    The problem is that as soon I select a selection other than the default that has no value, a red dotted line appears around the selection and no matter what selection I make I get the same thing and the form can't be submitted.

    Here is what the form, rules and result looks like.  Simple validation but can't figure out why it doesn't work.

    ENTER VALUE > 0  MAKES REASON FIELD REQUIRED (this is correct behavior)
                                                                            

     

     MAKE A SELECTION THAT HAS A VALUE OF "VAC" and it still says "FIELD CANNOT BE BLANK"

    HERE IS THE VALIDATION RULE


     

     


  • 11-14-2010 09:42 AM In reply to

    Re: Rule Validation not working for drop-down list

    Fixed. Just need to add a and BLANK condition

Page 1 of 1 (2 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.