INFOPATH 2007 AddDAYS FORMULA NOT WORKING IN BROWSER - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

INFOPATH 2007 AddDAYS FORMULA NOT WORKING IN BROWSER

Last post 01-23-2009 12:29 PM by bogdantc. 5 replies.
Page 1 of 1 (6 items)
Sort Posts: Previous Next
  • 01-23-2009 05:38 AM

    INFOPATH 2007 AddDAYS FORMULA NOT WORKING IN BROWSER

    Hi All

     I'm using the addDays formula in Infopath 2007 and it works on preview, and I published it on sharepoint form library when I open it on the calculations it shows "#ERR?". Your assistance will be highly appreciated.

     

    Thank you

    Lorraine

  • 01-23-2009 05:47 AM In reply to

    Re: INFOPATH 2007 AddDAYS FORMULA NOT WORKING IN BROWSER

    Hi,

    Make sure that the field data type should be whole number(integer) and you should enter the integer value in the field.

    Swathip
    www.ggktech.com
  • 01-23-2009 05:52 AM In reply to

    Re: INFOPATH 2007 AddDAYS FORMULA NOT WORKING IN BROWSER

     

    Thank you Swathip

     I'm using a number on the days to add, e.g addDays(DateTime,30)

  • 01-23-2009 05:55 AM In reply to

    • bogdantc
    • Not Ranked
      Male
    • Joined on 05-27-2008
    • Bucharest
    • Posts 25

    Re: INFOPATH 2007 AddDAYS FORMULA NOT WORKING IN BROWSER

     I usually work having in mind 2 datetime formats, English and Romanian. First thing I would check would be to see if the server has the same dateformat as my pc. Second thing I would use a try catch and send a lot of Ui.Alerts until I find the real problem.

    Able was I ere I saw Elba
  • 01-23-2009 06:07 AM In reply to

    Re: INFOPATH 2007 AddDAYS FORMULA NOT WORKING IN BROWSER

    Thanks Bogdantc

     The form has the same dateformat as my VM,and I'm using English datetime format. I tried to get the date that I use on the calculations seperately and it does return the right that and the number of days that I adding are right as well, the only problem is the formula when is published but if I preview the formula works perfect.

     

    Thank you

  • 01-23-2009 12:29 PM In reply to

    • bogdantc
    • Not Ranked
      Male
    • Joined on 05-27-2008
    • Bucharest
    • Posts 25

    Re: INFOPATH 2007 AddDAYS FORMULA NOT WORKING IN BROWSER

    You say you are developing in InfoPath 2007. I am thinking maybe you might have on SharePoint as default InfoPath 2003 and we all know that AddDays is available only in 2007. Are you saving it as 2003 compatible?

    If the above is not valid either, could you please post a template ? Maybe the solution would be more evident having the template to test ...

    Able was I ere I saw Elba
Page 1 of 1 (6 items)
Copyright © 2003-2019 Qdabra Software. All rights reserved.
View our Terms of Use.