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QDABRA DATABASE ACCELERATOR V2.3

Create a SharePoint Data View that uses GetListItems to
access DBXL forms

SharePoint Designer allows you to receive data from DBXL’s web methods, and one method is particularly
interesting when creating a SharePoint Data View. The DBXLDocumentService web service contains
GetlListitems, which retrieves promoted properties in the form and displays them as columns in SharePoint.
GetlListltems has an added bonus: it will respect DBXL permissions.

PRE-REQUISITES

To successfully complete this tutorial, you MUST have the following:
e Aform template with promoted properties.

e This form template is published as a Document Type in DBXL, and documents have already been
added.

e  Microsoft Office SharePoint Designer 2007.

RELATED DOCUMENTATION

e Another option involves first creating a Database (SQL) Mapping for your DBXL Document Type,
then configuring your data view to retrieve data from SQL. Please read the document called Create
a SQl-based SharePoint Data View to access your DBXL Forms for information on this alternative
method.

e If you require DBXL Document-Level permissions, please read Use Document-Level Permissions for
browser-based forms in a data view.

TUTORIAL

A. Create a new SharePoint List.

1. Navigate to the site where you wish to add this data. Click on Site Actions and then click
on Create.
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2. Under Custom Lists, click on Custom List.
3. Enter a Name, a Description, and select whether the list will show in the Quick Launch.
When done, click Create.

B. Modify the list using SharePoint Designer.
4. Open this newly created SharePoint page in SharePoint Designer by selecting File > Edit
with SharePoint Designer in Internet Explorer. You can also directly open it by clicking
Open icon in SharePoint Designer and entering your SharePoint library URL.
5. Click on Data View > Manage Data Sources.
6. Under XML Web Services, click Connect to a web service.

Data Source Library X
x| Data Source Library ‘DataSi 4 b X

e et
Select a data source to create a Data
View:

[=] Current Site

# SharePoint Lists (7)

# SharePoint Libraries (17)
| Database Connections (0)
] XML Files (53)

| Server-side Scripts (0)

] XML Web Services (0)

H @ @

Connect to a web service...

[+ Business Data Catalog (0)

# Linked sources (0)

7. Enter the Service Description Location (URL) to the DBXLDocumentService, usually located
at http://<servername>/QdabraWebService/DbxIDocumentService.asmx, and click
Connect Now.
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Service description location:

http: /| <servername >/QdabrawebService/DbxIDocument Service. asmx|

l Browse... |

Example: http:/fexample.com?WSDL

Establish a connection with the specified
MJ XML Web Service,

Select which data command to configure:

8. Inthe Operation dropdown, select GetMyListltems. (You can use Getlistltems instead to
list all documents, if permissions are not a part of your solution.)
9. Double-click on the listName and viewName parameters, and enter the name of the

Document Type you wish to query. Click OK.

Data Source Properties

General | Source | Login

Service description location:

Example: http:/fexample.com?WsDL

Select which data command to configure: | sglect

query

viewFields

rowLimit s:string
queryOptions

v
Select Connection Info
Service DbxIDocumentService
Name:
Port: [DbxlDocumentServiceSoap v ]
Address:  http:jf JQdabraWebService/DbxIDocumentService. asmx
Operation: |  GetlistItems v |
Parameters (* required):
MName Value Element  Type Runtim. ..
listMName MyDocType s:string O
viewhName MyDocType s:string

o000y
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GetlListltems limits the results returned in your SharePoint list to the first 100 documents. In order to
increase this, set the rowLimit to more than 100 rows.

- arameter
Address:  http://dbxl-test

e 1 Name:
Operation: | GetListItems |
Parameters (* required): Value:
Name 1000 v
listName Element: 1o0of1
viewhame Mazimum Allowed: 1
query [] The value of this parameter can be set via a Web Part connection
viewFields
rowLimit [ ok | [ Cancel ]
queryOptions L] I

10. The new web service connection will show up under XML Web Services in the Data Source
Library. Click the down arrow for the connection you just created and click on Show Data.

=] XML Web Services (1) ‘

®, DbxIDocumentService on db

A ShowData

Insert Data Source Control

Link to another Data Source...
=3 Copy and Modify...
3
=l Saveas..
)= Mail Recipient (as Attachment)...
X Remove

Propetties...

The Data Source Details tab will show the columns retrieved from the Document Type. You can design the
page as desired. For this example, we will do the following:

11. Hold down the Control key and use your mouse to click on the DocID, Name, Author and

Description (along with any other columns you wish to displat). Then drag and drop these
columns into the location on the page where you wish to display this data.
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C.

Data Source Details X

‘ary |Data Source Details ‘Web 4 b X
Current Data Source:
DbxIDocumentService on dbxl-test3..

| Insert Selected Fields as... ¥ |
[ [y GetlistIitemsResponse =
B [listitems
B [Ggrs:data
(&] ItemCount

Elgrz... [2/3] «»
=]DociD
(& Link

5 BYX

(] VersionNo
(=] RefID

(& IsLocked

= L;c_k_edBy

(5] LockExpires

@ LodConme...
g —

Eoesaipton

IPFS-enable the Data View (Optional).
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The steps in this section (C) are only necessary if your form template has code, needs to be browser-
enabled, and has already been admin-deployed. If this is not necessary, do the following to add a hyperlink:

- Right-click on any entry in the DocID column and click Hyperlink.
- Enter {@Link} in the Address field and click OK.
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12. Right click on any entry in the DocID column and click Hyperlink. We will now create a
hyperlink to IPFS-enable the forms.
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‘DocID Author MName Description
i Author: jo-{td.ms-vb|
6 jo-anne Expense Report test1

13. Click on the Parameters button.

Edit Hyperlink

Link to: Text to display: |[{@DocID} } | ScreenTip. .. |

9 Look in: (@ http:y v| [ =
Existing File or | ‘ — ‘
Web Page = A | Bookmark... |
Current :]
Foxce © Target Frame...
Place in This ‘*j
Document Browsed | | Parameters... |
Pages |/ 3
]
Create New Recent 2l
Document Files IEE]|
IE5]| v
e Address: | v] [ Remove Link ]
E-mail Address
o)

14. In the Path text field, enter http://<your server name>/_layouts/FormServer.aspx
15. Click Add button. Enter XsnlLocation in the Name field.
16. Enter value /FormServerTemplates/<your published xsn name>.xsn, and then click OK.

Modify Parameter

Name:

‘snLocation v|

| Value:

‘IFormServerTempIatesIExpenseReportPubﬁshedS. v ]

I OK ][ Cancel ]

17. Click Add button.
18. Enter DefaultltemOpen in Name, and Value equal to 1. Click OK.
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Add Parameter @

Name:
[DefaultltemOpen v ]
Yalue:
[1 v ]

[ OK ][ Cancel ]

19. Click Add button again.
20. Enter DoclID and select XSL:DoclID in the Value dropdown.

Add Parameter @ |

Name:
DocID v |
Value:
v

XSL: Description -~
%SL: LockComments
XSL: Author

“XSL DocID ] v

21. You will get something like this:

Add Parameter

Name:
{@Doclo v ]
Value:
“{@DOCID} v ]

I OK I[ Cancel ]

22. Remove the ‘@’ of DoclD in the Name field and click OK.
23. Repeat steps 19 —22, this time using Name:
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Add Parameter @

Name:
{Name v
Value:

v
%SL: LockedBy -~
XSL: YersionNo
XSL: Name
%SL: Modified v

24. Click the Add button. Enter Openin for Name and Browser as Value. Then click OK.
25. You will now have your parameters listed as follows:

Hyperlink Parameters @

Path

’http: Jidbxl-test4)_layouts/FormServer.aspx

[ Insert Field Value ]

Query string

‘ Name Yalue Move Up |
¥snLocation [FormServerTemplates/ExpenseReportP...

DefaultItemOpen 1
DocID {@DocID}

Name {@Name}

Openln Browser

[ Add... ][ Modify. .. ][ Remove ][ Clear ]

[ OK ][ Cancel ]

26. Click OK.
27. Verify that the link generated in the Address bar is correct. The address should be:
http://<yourservername>/ layouts/FormServer.aspx?XsnLocation=/FormServerTemplates

/<templatepublished>.xsn&DefaultltemOpen=1&DocID={@DocID}&Name={@Name}&Ope
nin=Browser
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4

Link to: Text to display: ]{@DocID} J
EI Look in: [xﬂ http:f) v]
Existing File or
Web Page | o | Bookmark... l
Current (3
Folder
[€6] | B Target Frame...
Place in This 2l
Pages 3]
Create New Recent )
Document Files IEE]|
] v
Address: [http:h 1_layouts/FormServer.aspx?XsnLocation=/FormS VI ||£x|
E-mail Address
[ OK ] [ Cancel ]

28. Click OK.

Data View sorting and grouping (Optional)

29. Click on the arrow to the right of the table, called Common Data View Tasks, and click on

Sort and Group.

Common Data Yiew Tasks |

Filter:

Sort and Group:

Paging:
Edit Columns...
Change Layout...

Data View Preview:

[[] show with sample data

Conditional Formatting...
Web Part Connections...

Parameters...

Refresh Data Yiew

Data View Properties...

Default

30. Select DocID and click Add >>. Repeat for Author.
31. Click Author in Sort order, click Move Up, and then click Show group header. Click OK.
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Sort and Group

Available fields:

Created
CreatedBy
Description
IsLocked

Link
LockComments
LockedBy
LockExpires
Modified
ModifiedBy
MName

RefID
VersionMo
More Fields ...
Add Sort Expression...

Add >>

<< Remove

Move Down

Sort order:

Author
» DocID

| Sort Properties
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)X

(3 ascending
(O Descending

[ Edit Sort Expression... ]

Group Properties
Show group header
(3) Expand group by default
(O Collapse group by default
[]show group footer

[ Advanced Grouping... ]

[ OK ][ Cancel ]

32. Click File > Save to save the changes to your SharePoint List.
33. InInternet Explorer, open the URL to your SharePoint List

E. Paging (Optional)

Should your document type contain a large amount of documents, you can use paging to improve

performance. For more info, see this page.

34. Click on the arrow to the right of the table and select Paging.

Filter:
Sork and Group:
Paging:

1<J Common Data Yiew Tasks

Edit Calumns. ..

Change Layauk, .,

Data Yiew Preview: | Default

™ Show with sample data

Parameters...

Conditional Formatting.. .

Web Part Conneckions. ..
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[Daka Yiew Properties, ..
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35. Select the Paging tab, then select the option to Display items in sets of this size. Enter the
number of items you wish to display per page.

Data Yiew Properties e

zeneral I Layouk I ®oLT Source  Paging |Eu:|iting I

Record sets
i~ Dizplay all ikems
{* Display items in sets of this size: |1|:|_
™ Limit the total number of items displayed ko: W

36. Click File > Save to save the changes to your SharePoint List.
37. InInternet Explorer, open the URL to your SharePoint List to view the change.

UPGRADING FROM PREVIOUS VERSION OF DBXL

In DBXL v2.3, the encoding of promoted properties has changed. This affects users of SharePoint web parts
or data views that make use of promoted properties that contain spaces. Therefore, all data views using
GetMyListltems or GetListltems that have promoted properties containing spaces will no longer have the
_X005F in the name. For example, ‘Status Code’, which was ‘Status_x005F x0020_Code’ is now
‘Status_x0020_Code’. If you upgrade from a previous version of DBXL to DBXL v2.3, you will need to update

your data view.

Copyright 2009 Qdabra Software. All rights reserved. Revised: 2014-10-07 3:24:17 PM



	QDABRA DATABASE ACCELERATOR V2.3

	PRE-REQUISITES

	RELATED DOCUMENTATION

	TUTORIAL

	UPGRADING FROM PREVIOUS VERSION OF DBXL



