"Include Data for Active Form Only" doesn't work - InfoPath Dev
in

InfoPath Dev

Having trouble finding a blog or post that answers your question? Check out our Custom Search Page

"Include Data for Active Form Only" doesn't work

Last post 05-06-2013 10:55 AM by michaelgchu. 9 replies.
Page 1 of 1 (10 items)
Sort Posts: Previous Next
  • 10-30-2007 08:08 AM

    • SusanH
    • Not Ranked
    • Joined on 10-30-2007
    • Posts 3

    "Include Data for Active Form Only" doesn't work

    I am attempting to display the SharePoint List ID that is assigned to the form, once you save the form, on the next time that you open the form.  I have created a Secondary Data Connection and successfully hooked up to the SharePoint list.

    If I add a Repeating Section in my control, and bind up the data, I indeed get back every field I'm asking for, such as ID, created by, content type, etc.  However, what I want is only to show that data for the active form.  Everywhere I can find suggests that modifying the data source, and selecting "Include Data for the Active Form Only" should filter the data returned, to only the appropriate data.

    However, when I do this and open up an existing form, or create a new one, I get no records returned at all.  Can anyone point me to what I might need to look at to ensure I have this set up properly?

     

    Thanks in advance

    Susan H

  • 10-30-2007 02:00 PM In reply to

    Re: "Include Data for Active Form Only" doesn't work

    I've never heard of doing that. What do you mean by "only show the data for the active form"?

    If you are talking about just "showing" certain fields from the returned collection of fields -- I'm guessing you already know that you can just delete some columns off the repeating table to show just the fields you want -- but I suspect you are referring to something else. If so, please elaborate.

  • 11-01-2007 11:19 AM In reply to

    • SusanH
    • Not Ranked
    • Joined on 10-30-2007
    • Posts 3

    Re: "Include Data for Active Form Only" doesn't work

    Greg:

    Thank you for responding, and I'm sorry for the delay with answering.  I'm still struggling with this, both from a Managed Code perspective, as well as just data binding.  In this article, it shows exactly what I mean.  When setting up the data connection in Step 3, he selects his fields and check the checkbox on the bottom - the checkbox reads "Include Data for the Active Form only".

    http://blogs.msdn.com/infopath/archive/2006/11/22/workflow-user-experience-in-infopath.aspx

    Somehow there is a link or a reference between the current instance of the form, and the data source.  In my case, when I do NOT check that checkbox, I get data elements for every form in the form library.  When I DO check the checkbox, I get back 0 records.  This is in the very same form library which uses this form, so I would have thought there was some "linkage" up. 

    To clarify:  All I'm trying to do is to get the Form ID that is automatically generated for the form in question, and show it in the form.  When I say ID, I mean the ID field that is auto-assigned every time you create and save a new form.  I would expect that this would not be filled in until after the form has been saved for the first time, I'm not sure.

    Thanks for any help you can give.

    Sue

  • 11-01-2007 11:28 AM In reply to

    Re: "Include Data for Active Form Only" doesn't work

    Hi

    Just going through the workflow I see what you mean, with both your answer and this in mind I think that the reason you are pulling zero instances back when the form has not been submitted to the SharePoint list so that it pulls back nothing.  If not ticking this box pulls back everything at least you data connection is alive and well it is the filtering on current form that is causing you issue.

    If you were trying to report the ID back to the user on submission run it as an action after the submission to SharePoint to display a dialogue box containing the ID number from the main connection to SahrePoint as this will be populated on submission.

    If this isn't your scenario get back to me and I will see if I can help further

    Cheers

    Adam Harding
    Wales
    UK
  • 03-10-2008 01:12 PM In reply to

    Re: "Include Data for Active Form Only" doesn't work

    Sue,

    Did you ever figure this out?  I'm running into the same issue.

    Thanks much.

    Deepak.

     

    Deepak Gupta
  • 03-11-2008 10:05 AM In reply to

    Re: "Include Data for Active Form Only" doesn't work

    A colleague of mine suggested the following method to resolve the issue:

    1. Create a field called My_ID on the InfoPath form and expose it as a dependency property when you publish the form.
    2. Create a SharePoint Designer workflow that would be kicked when a new item is added to the list.
    3. Add a Step that assigns the List Item's ID to My_ID

    Hope this helps.

     

    Deepak Gupta
  • 06-04-2008 06:36 AM In reply to

    Re: "Include Data for Active Form Only" doesn't work

    I have had similar problems when trying to query workflow status to change views. After far too much time messing around with it I have discovered what was causing our problems. It was simply a case of the filename. It seems when querying between the infopath form and sharepoint it doesnt like spaces in the file name if your trying to pull data for that form only. I have changed the submit file name to ensure it never has spaces and it now works perfectly. Im wandering if your problem is similar?

     

     

  • 07-22-2009 11:53 AM In reply to

    Re: "Include Data for Active Form Only" doesn't work

     I think you can use the Expression box instead of creating a full field .

    you are only reading the entry of the list item ID , as a connected data set ( from the Data Source)

    you need to remember to create a unique data source for that one.

     

    Let me know if that helps

    -George

     

  • 07-23-2012 10:07 AM In reply to

    Re: "Include Data for Active Form Only" doesn't work

     nickwjm, you're my hero. That's the problem I was pulling my hair out over. Now I've removed spaces from filenames and I'm working fine.

  • 05-06-2013 10:55 AM In reply to

    Re: "Include Data for Active Form Only" doesn't work

    nickwjm, you are my hero too. Form filenames was the problem for us, although instead of spaces being the problem, it was apostrophes. (Interestingly, spaces are fine - we have lots of spaces in all our filenames)
Page 1 of 1 (10 items)
Copyright © 2003-2017 Qdabra Software. All rights reserved.
View our Terms of Use.