Saveto SharePoint multiple attachments error - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Saveto SharePoint multiple attachments error

Last post 05-16-2018 10:40 AM by Hilary Stoupa. 7 replies.
Page 1 of 1 (8 items)
Sort Posts: Previous Next
  • 05-15-2018 03:44 PM

    Saveto SharePoint multiple attachments error

    Hi All i have an InfoPath Filler form that has a section to allow the user to submit to a fileserver, multiple attachments. I've done this before on a couple of forms, some to sharepoint the others to the fileserver but each time they utilized the qRulesFilename for the naming convention. Works beautifully. Now I want to specify a filename, made sure it's datetime stamped and all, but only one of the files will actually succeed. The second or latter files always fails. I am using the namexpath switch and it is a relative path to the filename attribute. My Filename node is repeating and NOT in a repeating group but it in a container non repeating folder. Please HELP! I'm up against a wall and cannot meet my deadline if this piece isn't working. :( ** P.S. ** i forgot to mention if i remove the namexpath switch and let qRules name it, all files update perfectly.
  • 05-15-2018 03:57 PM In reply to

    Re: Saveto SharePoint multiple attachments error

    If you'll attach your form to a reply, or email to support AT qdabra DOT com and reference this post, I'll take a quick look at your template tomorrow. Can you also let me know the error you are getting in the Qdabra Rules Error node? Or drag the execution history onto your form so you can see the errors there...
    Hilary Stoupa

  • 05-15-2018 04:37 PM In reply to

    Re: Saveto SharePoint multiple attachments error

    I am but its the standard "Failed to SavetoSharepoint" even though one did go. Can you please remove this so no one else can see it after? i have client info on this.
  • 05-15-2018 05:00 PM In reply to

    Re: Saveto SharePoint multiple attachments error

    I downloaded the file & removed it from your post - I'll take a look first thing tomorrow. :)
    Hilary Stoupa

  • 05-15-2018 05:03 PM In reply to

    Re: Saveto SharePoint multiple attachments error

    Have i Told you i love you lately? :) Thanks Hil.
  • 05-16-2018 08:13 AM In reply to

    Re: Saveto SharePoint multiple attachments error

    I think the problem is that your namexpath param is not relative to the file attachment node. Try this instead: /namexpath=@my:prat_file_name
    Hilary Stoupa

  • 05-16-2018 10:24 AM In reply to

    Re: Saveto SharePoint multiple attachments error

    It worked!! I owe you dinner or a bottle of wine or a box of chocolate or something!, but I owe you none the less. Thanks again Hilary!
  • 05-16-2018 10:40 AM In reply to

    Re: Saveto SharePoint multiple attachments error

    Fantastic - glad that was it! I was hoping that was the problem...
    Hilary Stoupa

Page 1 of 1 (8 items)
Copyright © 2003-2018 Qdabra Software. All rights reserved.
View our Terms of Use.