Infopath cannot submit form - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Infopath cannot submit form

Last post 05-07-2018 10:25 AM by nrathbun. 4 replies.
Page 1 of 1 (5 items)
Sort Posts: Previous Next
  • 05-04-2018 08:38 AM

    Infopath cannot submit form

    For one specific user, I am getting this error:

    Infopath cannot submit the form.

    Some rules were not applied.

    The query cannot be run for the following DataObject: GetDocumentNumber.

    Infopath cannot run the specified query.

    Infopath either cannot connect to the data source or the service has timed out.

     

    I've already checked this users permissions on SharePoint (and in general), it happens when he is directly connected to the network or on wireless. The event logs tell me jack. Error ID 16, google is no help on that id either. but this is the only user who cannot submit the form. It is been a day and a half of googling my head off, and no definite answers. Infopath opens in Filler. I would greatly appreciate any help.

    The user is on Windows 10

    Infopath 2013

  • 05-04-2018 08:58 AM In reply to

    Re: Infopath cannot submit form

    So - GetDocumentNumber data connection queries a SharePoint List or Library? Make sure this user has the correct permissions on it (I'm sure you've already done this, but wanted to double check). Is it possible to have the user log into a different machine to rule out any machine level issues?
    Hilary Stoupa

  • 05-04-2018 10:13 AM In reply to

    Re: Infopath cannot submit form

     It is a Library I believe. No joy on another computer either. he logged into his account on my computer to test it, and same error.

  • 05-04-2018 03:24 PM In reply to

    Re: Infopath cannot submit form

    Check that data connection that's failing so you can see what it is querying. Make sure the user has access - like, if its a library, have him open the library....
    Hilary Stoupa

  • 05-07-2018 10:25 AM In reply to

    Re: Infopath cannot submit form

     I figured it out. Apparently, the GetDocumentNumber query does jack. It used to, and then they took the query out, but anyways, there is a tracking number box on the form that needs to be filled out. however, it is not marked as having to be required on the page.  Once you fill that number in, the document sends perfectly.

Page 1 of 1 (5 items)
Copyright © 2003-2018 Qdabra Software. All rights reserved.
View our Terms of Use.