InfoPath 2013 envelope object issue with Outlook 2016 - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

InfoPath 2013 envelope object issue with Outlook 2016

Last post 01-22-2018 02:56 PM by The Noob. 4 replies.
Page 1 of 1 (5 items)
Sort Posts: Previous Next
  • 01-11-2018 05:50 AM

    InfoPath 2013 envelope object issue with Outlook 2016

    Hi, I've seen a couple posts regarding the compatibility issues with switching views from for to an email view and not displaying the envelope fields to add\remove recipients, edit subject and sending the email. All my eggs are in one basket with this application and I've been hopeful seeing a workaround. Please let me know if there are any at this point. Thank you in advance for any assistance.

     

    My current setup is:

    Windows 7 desktops
    InfoPath 2013
    Coding in VS2012
    Outlook 2013
    SharePoint  2013

     

    We're migrating to Windows 10 and Outlook 2016.  

  • 01-12-2018 09:52 AM In reply to

    Re: InfoPath 2013 envelope object issue with Outlook 2016

     I have IP 2013 + Outlook 2016 + Windows 10 if you'd like to give me a test form with your code in it.... I can try it on my machine & see what happens. Or are you saying you've been testing & had an issue?

    Hilary Stoupa

  • 01-12-2018 01:13 PM In reply to

    Re: InfoPath 2013 envelope object issue with Outlook 2016

     Hi Hilary,

     I'm working fine in my current configuration using IP 2013 + Outlook 2013 on Windows 7. But when I use the same form on a Windows 10 with IP 2013 + Outlook 2016 the envelop will not open when switching view uses the below custom VB code. I keep getting an error that I don't have Outlook 2013 as my default email client.  

     

    Me.ViewInfos.SwitchView("IMComms")


    If Me.CurrentView.Window.MailEnvelope.Visible = False Then


    Me.CurrentView.Window.MailEnvelope.Visible = True


    Else


    Me.CurrentView.Window.MailEnvelope.Visible = True


    End If

      

  • 01-12-2018 03:04 PM In reply to

    Re: InfoPath 2013 envelope object issue with Outlook 2016

     You may need to change your approach and use Microsoft.Office.Interop.Outlook instead. The first post in this thread has a sample (hard to read, but copy it out in a text editor and add some line breaks!)http://www.infopathdev.com/forums/p/26381/91611.aspx#91611

    Hilary Stoupa

  • 01-22-2018 02:56 PM In reply to

    Re: InfoPath 2013 envelope object issue with Outlook 2016

     Thank you Hilary! I'll mess around with it.

Page 1 of 1 (5 items)
Copyright © 2003-2018 Qdabra Software. All rights reserved.
View our Terms of Use.