Rule do not work when you have two or more conditions in Infopath2013 - InfoPath Dev
in

InfoPath Dev

Having trouble finding a blog or post that answers your question? Check out our Custom Search Page

Rule do not work when you have two or more conditions in Infopath2013

Last post 12-08-2017 10:26 AM by Takele. 7 replies.
Page 1 of 1 (8 items)
Sort Posts: Previous Next
  • 12-06-2017 12:52 PM

    • Takele
    • Not Ranked
    • Joined on 11-30-2017
    • Posts 5

    Rule do not work when you have two or more conditions in Infopath2013

    I was updating a previously done InfoPath form to update ordinances to be displayed whenever inspectors see any violations. For example, there are different items in the form. These items have check boxes to indicate the presence or absence of violations in the field. Violations are related with city ordinances. These different violations can also be related with the same city ordinances. So, what I wanted to do is when they see different violations and check the boxes in the form, I want the form to display the specific city ordinances related with the violation at the bottom of the form (in a table). However, recently, the rule (formatting) does not work when you have more than two conditions. It works with one condition but not with two or more. Currently, I am forced to duplicate the same ordinances so that I can have rules for each condition......which may resulted in the same ordinances being displayed at the end of the inspection when two violations are because of a single city ordinances.   

     

    The condition I tried but did not work is ......Field1 is equal to True AND Field2 is not equal to True.

  • 12-06-2017 02:25 PM In reply to

    Re: Rule do not work when you have two or more conditions in Infopath2013

    Generally when I have trouble with conditional formatting it is either because I have my and / or mixed up, or because the fields don't have the values I think they do. Are Field1 & Field2 Boolean?
    Hilary Stoupa

  • 12-06-2017 02:35 PM In reply to

    • Takele
    • Not Ranked
    • Joined on 11-30-2017
    • Posts 5

    Re: Rule do not work when you have two or more conditions in Infopath2013

    Thanks for the response.  

    I do not think it is because of the mixed up. I have tried both AND/OR. The Field1 & Field2 are Optional_Boolean.

  • 12-06-2017 02:46 PM In reply to

    Re: Rule do not work when you have two or more conditions in Infopath2013

    So - I went to create a sample form (attached) and I did notice that since my conditions are "OR" conditions, after saving & re-opening, IP created multiple rules (one for each condition) - but I don't think that's what you are talking about here... at any rate, you can see that whether the section is displayed depends on more than one field value. Save the form locally, right click and select Design to open in design mode & preview.
    Hilary Stoupa

  • 12-06-2017 03:08 PM In reply to

    • Takele
    • Not Ranked
    • Joined on 11-30-2017
    • Posts 5

    Re: Rule do not work when you have two or more conditions in Infopath2013

     Thanks again. I saw your form.

     

    What I wanted is to display the  message when I check either Field 1, 2 or 3.

    I have not tried to combine different rules into one group but, on your form, when I tried 3 conditions under one rule, it only displayed the message appropriately when I check field 1 or field 3 OR both of them. However, it did not work when I checked the Field 2 box, .


  • 12-07-2017 06:50 AM In reply to

    • Takele
    • Not Ranked
    • Joined on 11-30-2017
    • Posts 5

    Re: Rule do not work when you have two or more conditions in Infopath2013

     The form is attached now.

    On the form I attached, I selected Field1 twice in stead of selecting Field 2 :) . So, it is working now on this particular form. However, on the form I have been working on, still I get the same issue.


     

  • 12-07-2017 09:45 AM In reply to

    Re: Rule do not work when you have two or more conditions in Infopath2013

    Sometimes when I'm having trouble with conditional formatting, instead of setting the rule to hide the control, I set it to change the fill color. You can use different colors for different rules. Maybe that will help you see what is going wrong.
    Hilary Stoupa

  • 12-08-2017 10:26 AM In reply to

    • Takele
    • Not Ranked
    • Joined on 11-30-2017
    • Posts 5

    Re: Rule do not work when you have two or more conditions in Infopath2013

     In stead of Formatting on the "Ordinances", I used Action in the Rule on the "Fields". It works now the way I wanted it.

     

    Thanks Hilary  

Page 1 of 1 (8 items)
Copyright © 2003-2017 Qdabra Software. All rights reserved.
View our Terms of Use.