Namespace - InfoPath Dev
in

InfoPath Dev

Having trouble finding a blog or post that answers your question? Check out our Custom Search Page

Namespace

Last post 10-12-2017 07:37 AM by Hilary Stoupa. 1 replies.
Page 1 of 1 (2 items)
Sort Posts: Previous Next
  • 10-12-2017 01:20 AM

    Namespace

    Hi

    I’m working on an existing InfoPath form and noticed some peculiarities.

    In the fields section the groups are pre-fixed with my:

    Also when I attempt to add a control to the form a binding dialog box opens.

    I’m trying to replicate the form so I can understand whats going on, could someone explain please?

     

     

    Filed under:
  • 10-12-2017 07:37 AM In reply to

    Is your existing form bound to a database or web service? Perhaps it was created from an existing schema? InfoPath uses the "my" namespace prefix when you add to the schema in the form designer - so if you were working with a form that you created from scratch, all the fields would use the "my" prefix - thus the prefix wouldn't show in the fields task pane. With a database bound form, or some other form where the schema was not entirely created in the designer, there may be a different namespace prefix for most of the nodes, and the "my" will show. Right click a node where the prefix doesn't show, and select "copy XPath" - paste the XPath into a text editor, and you'll see the namespace prefixes. If you are adding controls inside a section that is bound to the portion of the schema that can't be changed (i.e., locked) I'd think you would bet the binding dialog.... feel free to attach a screenshot under the Options tab if you need to in order to better describe what's happening - I may not quite be answering your questions. :)
    Hilary Stoupa

Page 1 of 1 (2 items)
Copyright © 2003-2017 Qdabra Software. All rights reserved.
View our Terms of Use.