Submit via Email - InfoPath 2013 to Outlook 2016 - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

Submit via Email - InfoPath 2013 to Outlook 2016

Last post 05-10-2018 05:04 PM by Hilary Stoupa. 23 replies.
Page 1 of 2 (24 items) 1 2 Next >
Sort Posts: Previous Next
  • 08-01-2017 04:07 AM

    Submit via Email - InfoPath 2013 to Outlook 2016

    Has anyone gotten the Submit through E-mail to work successfully for InfoPath 2013 with Office/Outlook 2016 installed? Previously with Office 2013, the user would click the button to submit via e-mail and the e-mail would show up in their inbox within a few seconds. With InfoPath 2013 and Office/Outlook 2016, the e-mail opens as an editable/draft e-mail in Outlook and it doesn't include the actual form data. Please tell me there's a work around for this... This Office 2016 rollout at my company has been a nightmare for all the work I did in InfoPath :(
  • 08-01-2017 12:11 PM In reply to

    Re: Submit via Email - InfoPath 2013 to Outlook 2016

     Wow, I've never seen this. I use InfoPath 2013 and Outlook 2016, and I can include the active view from the form in an email, and the user can't edit the email... is this an email form? Or a regular form with an email submit connection? Can you attach a screenshot under the Options tab in a reply?

     

    Hilary Stoupa

  • 08-01-2017 12:29 PM In reply to

    Re: Submit via Email - InfoPath 2013 to Outlook 2016

    Hi Hillary, Here's the important part of the VB code which is triggered when the button is pressed, showing the makeup of the e-mail itself.. This worked great with Outlook 2013. Second post will have the screenshot of what happens.
  • 08-01-2017 12:59 PM In reply to

    Re: Submit via Email - InfoPath 2013 to Outlook 2016

    And here's the screenshot of the template and what happens when I press the "Email" button. Sorry for all the redaction. With Office 2013, when the user clicks the Send E-mail button, InfoPath would popup a window with a confirmation of the e-mail fields and everything ready to send and the user would hit "OK" which would then send the e-mail. The pop up is from InfoPath, not Outlook, so I'm perplexed why it's not popping up now with Outlook 2016.
  • 08-07-2017 03:58 AM In reply to

    Re: Submit via Email - InfoPath 2013 to Outlook 2016

    Anyone have any ideas by chance? I'm really hopeful this is something that can be fixed - my director is now talking about coming up with an exit strategy to get out of InfoPath and we've only been on it since April after a year of development. :(
  • 08-07-2017 08:08 AM In reply to

    Re: Submit via Email - InfoPath 2013 to Outlook 2016

    I'm sorry, I forgot to get back to you. This must be an email form, right? Because a regular InfoPath form with an email data connection does NOT pop up an editable email message....
    Hilary Stoupa

  • 08-07-2017 08:21 AM In reply to

    Re: Submit via Email - InfoPath 2013 to Outlook 2016

    No worries Hilary - I greatly appreciate your help! This is a Filler Form published to SharePoint but I had created an E-mail Submission method to be able to optionally send templated e-mails. Sorry if my previous message was misworded, with Office 2013 when the user would click the button they would get a read-only confirmation window similar to this image I found on google images [which was published here, go figure!] ( http://www.infopathdev.com/photos/blog_pictures/images/58878/original.aspx )

    With Office 2016, as soon as I click that same button it doesn't give me that prompt anymore, it just opens a draft e-mail pre-formatted according to the code I had in my screenshot.

    So in your case using InfoPath 2013 and Outlook 2016, when you use an email submission button it still shows the read-only prompt like here? http://www.infopathdev.com/photos/blog_pictures/images/58878/original.aspx
  • 08-07-2017 08:27 AM In reply to

    Re: Submit via Email - InfoPath 2013 to Outlook 2016

    Yes, exactly - I get the read-only prompt.... I use 64-bit Office, what are you using?
    Hilary Stoupa

  • 08-07-2017 09:43 AM In reply to

    Re: Submit via Email - InfoPath 2013 to Outlook 2016

    I'm on 32-bit Office but 64-bit InfoPath, maybe that's the disconnect. I'm uninstalling InfoPath right now to reinstall with 32-bit and will see if that fixes it.
  • 08-07-2017 09:49 AM In reply to

    Re: Submit via Email - InfoPath 2013 to Outlook 2016

    Oh, good idea.... I can't remember if it was on the forum or in an email conversation, but I do recall talking to someone who had email issues w/ a mismatch.
    Hilary Stoupa

  • 08-07-2017 02:08 PM In reply to

    Re: Submit via Email - InfoPath 2013 to Outlook 2016

    Thanks for your help, Hilary! That's exactly what the issue was -- 32 bit and 64 bit don't jive. Once I switched InfoPath to 32 bit to match Office 2016 the e-mail is working beautifully again (what IT department still installs 32 bit on 64 bit machines?! Oye!)
  • 08-07-2017 02:33 PM In reply to

    Re: Submit via Email - InfoPath 2013 to Outlook 2016

    Thanks for the update, it's good to know what the issue is. :)
    Hilary Stoupa

  • 04-10-2018 06:23 PM In reply to

    Re: Submit via Email - InfoPath 2013 to Outlook 2016

    Hi there!  I am having the same issue as the above, but already have 32-bit Office and 32-bit InfoPath installed on 64-bit Windows 10. 

    Any other advice on how to resolve? 

    Issue 1:  same as above

    Before Office 2016 installed - user was prompted with the read-only email screen.  They could not modify the recipients, subject, or body.  

    Now with Office 2016 installed - an actual email pops up, and allows the user to modify everything.  The static text from the email template inside the form shows up at the top, but they can modify it.   

    Issue 2:

    The issue above is only happening on my form templates originally created using InfoPath 2013.  But I still have form templates that were originally created using InfoPath 2007.  And on those, I'm getting this error when the user clicks any of the submit buttons that send an email and save back to the library:

    "InfoPath cannot submit the form.  The parameter is incorrect."

    Any help would be appreciated, thanks so much!

    BTW - Hilary - I'm a big fan!  Your posts on here have helped me so many times over the years!  :)

  • 04-11-2018 08:52 AM In reply to

    Re: Submit via Email - InfoPath 2013 to Outlook 2016

    My setup has changed since I last posted versions - when I set up my new machine, I went w/ 32 bit Office for both InfoPath 2013 and Office 2016. I can't reproduce any of this, I'm afraid. My email submit pops up an un-editable email window. If I save a form as 2007 compatible, it works as expected as well.... any of your forms using code? Is this happening on more machines than just yours? Everything is updated, all patches applied?
    Hilary Stoupa

  • 04-11-2018 01:04 PM In reply to

    Re: Submit via Email - InfoPath 2013 to Outlook 2016

    Come to find out, it just needed a simple patch!  All users are now operational, thanks for the reply!

Page 1 of 2 (24 items) 1 2 Next >
Copyright © 2003-2018 Qdabra Software. All rights reserved.
View our Terms of Use.