infopath 2013 taking forever to publish to sharepoint 2013 - InfoPath Dev
in

InfoPath Dev

Use our Google Custom Search for best site search results.

infopath 2013 taking forever to publish to sharepoint 2013

Last post 07-26-2017 08:56 AM by Hilary Stoupa. 3 replies.
Page 1 of 1 (4 items)
Sort Posts: Previous Next
  • 07-24-2017 09:17 AM

    • nadz84
    • Not Ranked
    • Joined on 07-24-2017
    • Posts 2

    infopath 2013 taking forever to publish to sharepoint 2013

    Good day, I have a SharePoint 2013 list with over 16K list items. When the list was initially created, i had designed the form using Infopath 2013 and publishing the file was simple and fast (less than a minute) As the data got bigger, the "Quick publish" started taking more and more time. Today as i made minor modifications to the form and tried to "Quick Publish" to the SharePoint list, it has been over 24 hours since the form is "Communicating with the SharePoint site". I tried creating a template of the same list to to a new one that had no data, and published the same modified form which took less than a minute. I have no idea what could be causing this and what is the solution Note: I cannot use SharePoint designer 2013 due to IT Restrictions Help Please :)
    Filed under: , ,
  • 07-25-2017 07:40 AM In reply to

    Re: infopath 2013 taking forever to publish to sharepoint 2013

     Yuck. I wonder if adding indexes to the list (under the list settings) would help?

    Hilary Stoupa

  • 07-25-2017 10:15 PM In reply to

    • nadz84
    • Not Ranked
    • Joined on 07-24-2017
    • Posts 2

    Re: infopath 2013 taking forever to publish to sharepoint 2013

    Hi, Thanks for extending your help on this I haven't worked with Indexes before I've got many columns and not sure how to approach this, would appreciate if you can point me in the right direction otherwise im worried ill end up with a new problem to deal with :)
  • 07-26-2017 08:56 AM In reply to

    Re: infopath 2013 taking forever to publish to sharepoint 2013

     You can find more info here: https://support.office.com/en-us/article/Add-an-index-to-a-SharePoint-column-f3f00554-b7dc-44d1-a2ed-d477eac463b0?ui=en-US&rs=en-US&ad=US

    Basically, if you index the columns most often used for filters / queries you can improve performance. So, let's say you have a Project Number column and you know your users often filter the list by Project Number - you'd add an index to that. Or maybe there is a Department field and that is often used for grouping / sorting, you may want to index that. 

    Personally, I'd create a template with content & set this up on a test site. Verify the issue still occurs (can't publish a form update or it takes forever), add some indexes & see if it resolves the issue. I'm not much of one for testing in production. 

    Hilary Stoupa

Page 1 of 1 (4 items)
Copyright © 2003-2018 Qdabra Software. All rights reserved.
View our Terms of Use.